Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156384 - Logitech cordless mouse is not handled
Summary: Logitech cordless mouse is not handled
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-29 16:08 UTC by Sylvain Rouillard
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-03 10:13:30 UTC


Attachments (Terms of Use)

Description Sylvain Rouillard 2005-04-29 16:08:16 UTC
Description of problem:
'kcmshell mouse' does not show me the special tab I should get about the battery
status and such for my logitech cordless PS2 mouse.

Version-Release number of selected component (if applicable):
$ rpm -q kdebase
kdebase-3.4.0-5

How reproducible:
always

Steps to Reproduce:
1.kcmshell mouse
  
Actual results:
the control center part opens fine, but I only get the default 4 tabs.

Expected results:
I should also see a tab called Receiver that shows battery strength and channel
of mouse

Additional info:

$ dmesg | grep tech
logips2pp: Detected unknown logitech mouse model 62
input: ImExPS/2 Logitech Explorer Mouse on isa0060/serio1

For the record, here is what I received from the kde mailing list when asking
about my problem:

In kde control centre the mouse should have a new tab called Receiver that 
shows battery strength and channel of mouse. It works fine here under FC3.
It is appropriate to write to a kde list about test kde releases because kde 
needs the bug feedback but it is pointless to write to a kde list when you 
are running a fedora test as any problems are likely to be OS related not 
desktop-environment related. The new mouse feature depend on a working 
hal/dbus/usb setup si it can read that info so write to fedora about it.

Comment 1 Ngo Than 2005-05-03 10:04:32 UTC
The kc_input in KDE only supports USB mouse, it seems that your mouse is not
connected to USB port. Is the mouse connected to USB port?


Comment 2 Sylvain Rouillard 2005-05-03 10:12:46 UTC
Ow... no sorry, it's a PS/2 mouse.

I missed the fact that this feature was for USB mice only, my bad.

Apologies for the bother.


Note You need to log in before you can comment on or make changes to this bug.