Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156359 - file-roller doesn't recognize RAR archives
Summary: file-roller doesn't recognize RAR archives
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: file-roller
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
: 160991 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-29 13:15 UTC by Dawid Zamirski
Modified: 2013-03-06 03:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-29 14:57:29 UTC


Attachments (Terms of Use)

Description Dawid Zamirski 2005-04-29 13:15:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
When I right-click on a .rar archive the file roller complains about unsupported format. I have unrar-3.4.3-1.1.fc3.rf package installed which was left after upgrade from FC3. I have no problems extraxting the files using unrar x archive_name.rar in the console.

Version-Release number of selected component (if applicable):
file-roller-2.10.0-1

How reproducible:
Always

Steps to Reproduce:
1. Get any .rar archive
2. Right-click on the archive file and choose Extract Here
3. Read "Archive type not suporrted" error message.
  

Actual Results:  "Archive type not suporrted" error message.

Expected Results:  Extract the archive.

Additional info:

the unrar package that I have installed comes form dag repository and it was working ok in FC3.

Comment 1 David Zeuthen 2005-04-29 14:57:29 UTC
I believe this is fixed in Rawhide; according to
http://fileroller.sourceforge.net/ it was fixed in 2.9.3 and we ship 2.10.0 in
Rawhide. Also, the GNOME bug for this issue is this one

 http://bugzilla.gnome.org/show_bug.cgi?id=162188

but there is no patch attached to that bug. I suggest to upgrade to FC4 when it
is released as I won't backport this fix since rar isn't shipped in the Fedora
Core distribution.

Comment 2 Dawid Zamirski 2005-08-16 16:57:43 UTC
Hello

This issue seems to be resolved in version 10.0.3 Is there any chance to get it
into updates-released? 

Thanks,
Dawid

Comment 3 John Mahowald 2005-11-14 21:23:17 UTC
*** Bug 160991 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.