Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156355 - init scripts block when not using graphical boot and /var/gdm/.gdmfifo exists
Summary: init scripts block when not using graphical boot and /var/gdm/.gdmfifo exists
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 156461 156626 156695 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-29 10:31 UTC by Nils Philippsen
Modified: 2014-03-17 02:53 UTC (History)
6 users (show)

Fixed In Version: 8.10-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-29 15:56:58 UTC


Attachments (Terms of Use)
Patch as described above. (deleted)
2005-04-29 10:33 UTC, Nils Philippsen
no flags Details | Diff

Description Nils Philippsen 2005-04-29 10:31:42 UTC
Description of problem:

SSIA, the "echo ... > /var/gdm/.gdmfifo" blocks blocks if there is no gdm
running that waits for data on that FIFO.

Version-Release number of selected component (if applicable):

initscripts-8.09-1

How reproducible:

Easy

Steps to Reproduce:
1. Don't have "rhgb" on the kernel command line, have $GRAPHICAL=no in
/etc/sysconfig/init
2. Boot
  
Actual results:

Hangs when the FIFO is filled up.

Expected results:

Doesn't try to write inito the FIFO in this case.

Additional info:

I'll attach a patch that removes /var/gdm/.gdmfifo like other files beneath /var
when booting the system and checks for $GRAPHICAL==yes before echoing into that
FIFO.

Comment 1 Nils Philippsen 2005-04-29 10:33:08 UTC
Created attachment 113826 [details]
Patch as described above.

Comment 2 Bill Nottingham 2005-04-29 15:56:58 UTC
gdm early-login doesn't key off of GRAPHICAL. Probably best just to background
the echo for now... this will get cleaned up better later.

Will be fixed in 8.10-1.

Comment 3 Valdis Kletnieks 2005-05-01 01:07:09 UTC
It doesn't have anything to do with gdm-early-login keying off anything.  I
tripped over the problem in /etc/rc.d/init.d/network when it hit this code:

# Log that something failed
failure() {
  rc=$?
  #if [ -z "${IN_INITLOG:-}" ]; then
  #   initlog $INITLOG_ARGS -n $0 -s "$1" -e 2
  #fi
  [ "$BOOTUP" != "verbose" -a -z "$LSB" ] && echo_failure
  [ -x /usr/bin/rhgb-client ] && /usr/bin/rhgb-client --details=yes
  [ -w /var/gdm/.gdmfifo ] && echo "BOOTUP_ERRORS" > /var/gdm/.gdmfifo
  return $rc
}

Nils's patch appears to be the correct fix.

Comment 4 Bill Nottingham 2005-05-02 16:05:00 UTC
*** Bug 156461 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2005-05-02 18:19:35 UTC
*** Bug 156626 has been marked as a duplicate of this bug. ***

Comment 6 Bill Nottingham 2005-05-03 17:28:34 UTC
*** Bug 156695 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.