Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156354 - x86 bits leaks memory
Summary: x86 bits leaks memory
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Geoff Gustafson
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-29 10:11 UTC by Ramakrishnan T M
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-12 19:24:46 UTC


Attachments (Terms of Use)

Description Ramakrishnan T M 2005-04-29 10:11:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
When applications compiled on x86 are run on an IA64 machine with 2.4 kernel the application experiences memory growth and crashes. The same binaries works fine on an x86 machine with AS 3.0 (2.4 kernel) installed. The application uses api's like gethostbyname, communicates using sockets. etc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create an application as per description
2.Compile and create binaries on x86 machine
3.Run the same binaries on ia64 machine
  

Actual Results:  The application showed memory growth over a period of 4hours and crached. Memory levels reached 1 GB in some cases.

Expected Results:  The applications should have run without problem. The typical memory consumption is about 60 MB on x86 machine.

Additional info:

Comment 1 Ernie Petrides 2005-04-29 19:00:22 UTC
Please provide the source code to a simple reproducer program.  Thanks.

Comment 2 Ernie Petrides 2005-09-12 19:24:46 UTC
Closing due to lack of response.


Note You need to log in before you can comment on or make changes to this bug.