Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156344 - refresh rate 0Hz
Summary: refresh rate 0Hz
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-29 04:09 UTC by juxhin sado
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-30 07:15:27 UTC


Attachments (Terms of Use)
xrandr output from Fujitsu-Siemens Amilo Pro V2000 (deleted)
2005-04-29 12:22 UTC, Miloslav Trmač
no flags Details
X log from Fujitsu-Siemens Amilo Pro V2000 (deleted)
2005-04-29 12:25 UTC, Miloslav Trmač
no flags Details
the conig file you asked for (deleted)
2005-04-29 14:18 UTC, juxhin sado
no flags Details
the log file (deleted)
2005-04-29 14:19 UTC, juxhin sado
no flags Details
the xorg logfile (deleted)
2005-05-07 22:16 UTC, juxhin sado
no flags Details
config file (deleted)
2005-05-07 22:20 UTC, juxhin sado
no flags Details

Description juxhin sado 2005-04-29 04:09:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1

Description of problem:
i am doing #xrandr and the response i get is
 SZ:    Pixels          Physical       Refresh
*0   1024 x 768    ( 347mm x 260mm )  *0
 1    800 x 600    ( 347mm x 260mm )   0
 2    640 x 480    ( 347mm x 260mm )   0
Current rotation - normal
Current reflection - none
Rotations possible - normal
Reflections possible - none
obviouslyy ther is a problem refresh rate of laptops is always 60 Hz. i have a toshiba A15-s129. Intel� 852GM Chipset. 32 meg shared memory. 

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.FC3.13

How reproducible:
Always

Steps to Reproduce:
1.boot into gnome 
2.#xrandr in terminal
3.
  

Actual Results:  i printed it above

Expected Results:  refresh rate should have been 60 

Additional info:

Comment 1 Mike A. Harris 2005-04-29 04:21:59 UTC
Hmm.  You generally can not change the refresh rate on Intel hardware,
as the video driver is limited to what the BIOS provides.  Not sure if
what you're seeing is a real bug, or due to this limitation in the Intel
driver.  If the latter however, the output of xrandr could probably be
more clear about it.

Can you attach your X server log file and config file?  Once we've got
those, we'll try to determine if this behaviour is expected or not.

TIA

Comment 5 Miloslav Trmač 2005-04-29 12:22:56 UTC
Created attachment 113828 [details]
xrandr output from Fujitsu-Siemens Amilo Pro V2000

Comment 6 Miloslav Trmač 2005-04-29 12:25:39 UTC
Created attachment 113830 [details]
X log from Fujitsu-Siemens Amilo Pro V2000

This and the above is from FC3, xorg-x11-6.8.2-1.FC3.13

Comment 7 juxhin sado 2005-04-29 14:18:12 UTC
Created attachment 113843 [details]
the conig file you asked for

Comment 8 juxhin sado 2005-04-29 14:19:48 UTC
Created attachment 113844 [details]
the log file

Comment 9 Mike A. Harris 2005-05-02 17:34:32 UTC
all text file attachments should be mimetype "text/plain" so they can
be viewed in the web browser by clicking on them.  Please fix.

Thanks in advance.

Comment 10 juxhin sado 2005-05-07 22:16:44 UTC
Created attachment 114136 [details]
the xorg logfile

there you go

Comment 11 juxhin sado 2005-05-07 22:20:17 UTC
Created attachment 114137 [details]
config file

there is the second one

Comment 12 Mike A. Harris 2005-08-30 07:15:27 UTC
The file attachments in comment #10 and 11 are unreadable.

As mentioned above, the refresh rate only shows up correctly when it
can be determined.  When it can not be determined, the xrandr utility
displays 0Hz.  This is a cosmetic issue only, however if you would prefer
xrandr to display "N/A" (for not available) or some other more friendly
output, you can file a bug in the X.Org bugzilla at:

http://bugs.freedesktop.org in the "xorg" component, and an X.Org developer
will review your request.

Setting status to NOTABUG, as it has been determined this is not a bug,
but a cosmetic issue only.


Note You need to log in before you can comment on or make changes to this bug.