Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156328 - Evolution missing new-mail-notify plugin
Summary: Evolution missing new-mail-notify plugin
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-28 22:30 UTC by Phil Anderson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 16:18:54 UTC


Attachments (Terms of Use)

Description Phil Anderson 2005-04-28 22:30:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
mail-notify plugin is not being built in the current devel build.  This appears to be intentional 'for now':
* Thu Mar 17 2005 David Malcolm <dmalcolm redhat com> - 2.2.1-1
- The new-mail-notify plugin will not be built for now since the
upstream configure test now checks for dbus-glib-1 version <= 0.23.4
(to minimise problems caused by the API change)

With the mail notification applet being removed from gnome, this leaves users without any form of mail notification.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Install Evolution

Additional info:

Comment 1 Dave Malcolm 2005-04-28 22:49:12 UTC
However, this should be simple to fix; I intend to do this for FC4 final.

Thanks for the reminder.

Comment 2 Dave Malcolm 2005-05-10 16:18:54 UTC
The fix made it into this morning's Rawhide - please test!

Thanks

Comment 3 Phil Anderson 2005-05-10 22:40:22 UTC
Dave,

The plugin seems to be doing it's job, however that job is different to what I
expected.  It only seems to send a DBUS message saying there is new mail. 
Unless there is somthing (i.e. an applet) listening, nothing happens.

It might be worth thinging about putting in em-panel-applet:
http://lists.ximian.com/archives/public/evolution-hackers/2005-April/005369.html
http://www.gnome.org/~gicmo/random/em-panel-applet-0.2.tar.gz

I compiled this (needed to change DBUS_INTERFACE_FREEDESKTOP_ORG_LOCAL to
DBUS_INTERFACE_LOCAL) and it proudced a nice little applet for me which notified
me of new mail.  However, it segfaulted shortly after I read my mail.

I'm not sure if you want it in there, or what priority it would be (or if you
have better things to do), but I can take a look at the segfault in the next day
or two and try to come up with a fix.


Comment 4 Dave Malcolm 2005-05-12 02:46:44 UTC
Phil: thanks for looking into this; please can you file adding the applet as a
separate bug?  Thanks.  FC4 is deeply frozen feature-wise right now, so I think
your best bet is to package it up for Fedora Extras (which would be awesome)

Note that the DBus API changed at version 0.31; you'll need to ensure that the
applet is using the new API (I patched Evolution to allow this, but a mismatch
between DBus APIs could well be causing the segfault you saw: you may need to
patch the applet correspondingly)


Note You need to log in before you can comment on or make changes to this bug.