Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156311 - reporting: no way of getting reports out of Satellite on actions taken
Summary: reporting: no way of getting reports out of Satellite on actions taken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: unspecified
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brad Buckingham
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-28 20:34 UTC by Dave Johnson
Modified: 2010-01-30 03:48 UTC (History)
2 users (show)

Fixed In Version: sat530
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-28 23:23:43 UTC


Attachments (Terms of Use)

Description Dave Johnson 2005-04-28 20:34:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
Even though you can go into the individual jobs and see when they were completed this is very tedious when you need to report on 300+ jobs.  There needs to be a reporting engine or something.  Not sure if this is a bug or just an enhancement request.

Version-Release number of selected component (if applicable):
satellite 3.6

How reproducible:
Always

Steps to Reproduce:
1.  Reports do not exist
2.
3.
  

Actual Results:  Reports do not exist

Expected Results:  Reports do not exist

Additional info:

Comment 1 Mihai Ibanescu 2005-09-30 16:58:37 UTC
Sorry for the lack of feedback, this is treated as an enhancement and prioritized.

Comment 3 Tom Madden 2007-07-29 23:31:54 UTC
Talk to Rich/Tom/Todd for more details on this.

Comment 9 Clifford Perry 2009-08-21 01:50:02 UTC
Satellite 530 GA will provide API call:

system.listSystemEvents - details following. I wonder if this meets the need, or if us providing an example API script using this call with others is requested/required?

Cliff

-------

 Method: listSystemEvents
Description:
List all system events for given server. This includes *all* events for the server since it was registered. This may require the caller to filter the results to fetch the specific events they are looking for.

Parameters:

    * string sessionKey
    * int serverId - ID of system.

Returns:

    * array:
          o struct - action
                + int "failed_count" - Number of times action failed.
                + string "modified" - Date modified. (Deprecated by modified_date)
                + dateTime.iso8601 "modified_date" - Date modified.
                + string "created" - Date created. (Deprecated by created_date)
                + dateTime.iso8601 "created_date" - Date created.
                + string "action_type"
                + int "successful_count" - Number of times action was successful.
                + string "earliest_action" - Earliest date this action will occur.
                + int "archived" - If this action is archived. (1 or 0)
                + string "scheduler_user"
                + string "prerequisite" - Pre-requisite action. (optional)
                + string "name" - Name of this action.
                + int "id" - Id of this action.
                + string "version" - Version of action.
                + string "completion_time" - The date/time the event was completed. Format ->YYYY-MM-dd hh:mm:ss.ms Eg ->2007-06-04 13:58:13.0. (optional) (Deprecated by completed_date)
                + dateTime.iso8601 "completed_date" - The date/time the event was completed. (optional)
                + string "pickup_time" - The date/time the action was picked up. Format ->YYYY-MM-dd hh:mm:ss.ms Eg ->2007-06-04 13:58:13.0. (optional) (Deprecated by pickup_date)
                + dateTime.iso8601 "pickup_date" - The date/time the action was picked up. (optional)
                + string "result_msg" - The result string after the action executes at the client machine. (optional)
                + array "additional_info" - This array contains additional information for the event, if available.
                      # struct - info
                            * string "detail" - The detail provided depends on the specific event. For example, for a package event, this will be the package name, for an errata event, this will be the advisory name and synopsis, for a config file event, this will be path and optional revision information...etc.
                            * string "result" - The result (if included) depends on the specific event. For example, for a package or errata event, no result is included, for a config file event, the result might include an error (if one occurred, such as the file was missing) or in the case of a config file comparison it might include the differenes found.

Available since: 10.8

Comment 10 Clifford Perry 2009-10-28 23:23:43 UTC
2 months in a needinfo state. I feel we have with this API meet the request and since 5.3.0 is GA'd, moving this to closed, current release. 

Cliff


Note You need to log in before you can comment on or make changes to this bug.