Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156287 - RFE: Postfix with MySQL lookup support
Summary: RFE: Postfix with MySQL lookup support
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-28 16:56 UTC by Lev Novikov
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-21 10:11:03 UTC


Attachments (Terms of Use)

Description Lev Novikov 2005-04-28 16:56:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
It's is possible to make this thing in Core?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
.

Additional info:

Comment 1 Dirk Nehring 2005-06-03 06:33:55 UTC
That would be a great help for us. Nearly everything (including saslauthd) is
supporting mysql lookups, but for postfix it is disabled in the SPEC-File. Hey,
it's an one-liner, everything is prepared.

Comment 2 Thomas Woerner 2005-06-21 10:11:03 UTC
The problem with enabling MySQL in postfix is, that there is no way to make it a
module for postfix - it has to get compiled in.

As long as there is no way to build database support for postfix as modules,
there is no way to enable any database support for postfix, because all enabled
databases have to be installed to install postfix, then.

I am sorry, but this is a no-go, for now.


Comment 3 Markus Wigge 2005-06-21 10:36:50 UTC
That's wrong! The debian-guys do it. Look at their patch and packages, they have
a main package for postfix and additional packages with shared objects for ldap,
mysql, pgsql, pcre ...

I think it should be possible to add this to core.

Comment 4 Thomas Woerner 2005-06-21 11:40:44 UTC
Yes, they have a self-made inofficial patch for this. The patched version is not
able to list all available maps etc. anymore. The core functionality is not the
same. Even it is not clear if there are pitfalls or bugs in it.

Such a big change has to be made upstream.



Note You need to log in before you can comment on or make changes to this bug.