Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156281 - switching from DLM to GULM and back again can cause tags to be missing or added
Summary: switching from DLM to GULM and back again can cause tags to be missing or added
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-28 16:28 UTC by Corey Marthaler
Modified: 2009-04-16 20:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 16:30:56 UTC


Attachments (Terms of Use)

Description Corey Marthaler 2005-04-28 16:28:08 UTC
Description of problem:
I had a cluster with a DLM conf file and I then used the GUI to switch to a GULM
file and then back to DLM again. Here is what the file looked like before
starting the GUI and then after the lock switching:

<?xml version="1.0"?>
<cluster name="link-cluster" config_version="1">

<cman>
</cman>



<fence_daemon post_join_delay="20" post_fail_delay="20" clean_start="0"/>

<clusternodes>
        <clusternode name="link-10.lab.msp.redhat.com" votes="1">

                <fence>
                        <method name="single">
                                <device name="apc" switch="2" port="2"/>
                        </method>
                </fence>
        </clusternode>
        <clusternode name="link-12.lab.msp.redhat.com" votes="1">

                <fence>
                        <method name="single">
                                <device name="apc" switch="2" port="4"/>
                        </method>
                </fence>
        </clusternode>
        <clusternode name="link-08" votes="1">

                <fence>
                        <method name="single">
                                <device name="apc" switch="1" port="8"/>
                        </method>
                </fence>
        </clusternode>
</clusternodes>


<fencedevices>
        <fencedevice name="apc" agent="fence_apc" ipaddr="link-apc" login="apc"
passwd="apc"/>
</fencedevices>


<rm>
</rm>

</cluster>




AFTER (note the missing and added tags):

<?xml version="1.0" ?>
<cluster config_version="2" name="link-cluster">
        <fence_daemon clean_start="0" post_fail_delay="20" post_join_delay="20"/>
        <clusternodes>
                <clusternode name="link-10.lab.msp.redhat.com" votes="1">
                        <fence>
                                <method name="single">
                                        <device name="apc" port="2" switch="2"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="link-12.lab.msp.redhat.com" votes="1">
                        <fence>
                                <method name="single">
                                        <device name="apc" port="4" switch="2"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="link-08" votes="1">
                        <fence>
                                <method name="single">
                                        <device name="apc" port="8" switch="1"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <fencedevices>
                <fencedevice agent="fence_apc" ipaddr="link-apc" login="apc"
name="apc" passwd="apc"/>
        </fencedevices>
        <rm>
                <failoverdomains/>
                <resources/>
        </rm>
        <cman/>
</cluster>


Version-Release number of selected component (if applicable):
-42

How reproducible:
everytime

Comment 1 Corey Marthaler 2005-04-28 16:30:56 UTC
actually, that's just another way to represent the XML tags, instead of an open
and close tag, it just prints out one <cman/> tag. Not a bug.


Note You need to log in before you can comment on or make changes to this bug.