Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156279 - RTF files display as blank documents
Summary: RTF files display as blank documents
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openoffice.org
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 156320 164274
TreeView+ depends on / blocked
 
Reported: 2005-04-28 16:21 UTC by Stuart Winter
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2005-650
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 15:36:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:650 qe-ready SHIPPED_LIVE OpenOffice.org bug fix update 2005-09-28 04:00:00 UTC
OpenOffice.org 48600 None None None Never

Description Stuart Winter 2005-04-28 16:21:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
openoffice.org-1.1.2-24.2.0.EL3.i386
openoffice.org-i18n-1.1.2-24.2.0.EL3.i386
openoffice.org-libs-1.1.2-24.2.0.EL3.i386
openoffice.org-style-gnome-1.1.0-16.9.EL.i386

I up2dated a RHEL3 box which installed the above.
Open Office now displays RTF files as blank documents.

I have reverted to the Open Office from RHEL3-U4 and the document contents are once again visible.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-24.2.0.EL3.i386

How reproducible:
Always

Steps to Reproduce:
1.Install this new version of open office
2.Load an RTF file (I can provide you with some if necessary)
3.See a blank document.
  

Actual Results:  Blank document.
The file properties inside Open Office reports that it is an RTF file and displays its file size correctly.

Expected Results:  See the document's contents.

Additional info:

This is a serious problem - especially for our sales people who use RTF a lot!

Comment 1 Caolan McNamara 2005-04-29 07:25:37 UTC
This doesn't sound good.

Comment 3 Dan Williams 2005-04-29 15:52:38 UTC
Stuart:  could you attach an RTF or forward it if necessary?


Comment 5 Dan Williams 2005-04-29 16:23:44 UTC
Stuart:

Using RHEL3 U4 and OOo version 1.1.2-24.2.0.EL3, I tried to open this file:

http://www.ccel.org/u/unknowing/cloud.RTF

It opens correctly, not blank.  Can you confirm that, and also attach your blank
document to this issue or email it to me directly?

Comment 6 Dan Williams 2005-04-29 16:41:54 UTC
caolan: The test doc from Stuart actually doesn't display in 2.0 either
(1.9.93-1).  Seems to be a > 1.1.0 problem, any chance you could take a look as
well?  Just forwarded it to you.

Comment 7 Caolan McNamara 2005-05-03 09:56:36 UTC
Submitted a fix for 2.0 as ooo#48600#

Comment 10 Dan Williams 2005-05-04 21:07:35 UTC
Fix integrated to pkgcvs, building RHEL4 test packages.

Comment 15 Dan Williams 2005-07-21 13:32:52 UTC
Confirmed fixed with openoffice.org-1.1.2-27.2.0.EL3

Comment 17 Stuart Winter 2005-08-24 09:28:56 UTC
Hi

Is it possible to have even a test version of openoffice?
This user is now on RHEL4 and still has this problem.

Thanks

Comment 18 Dan Williams 2005-08-24 13:27:53 UTC
stuart - http://dcbw.boston.redhat.com/ooo/


Comment 20 Red Hat Bugzilla 2005-09-28 15:36:30 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-650.html



Note You need to log in before you can comment on or make changes to this bug.