Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156209 - FC4 rebuild failed
Summary: FC4 rebuild failed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fwbuilder
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-28 13:04 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 17:10:57 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2005-04-28 13:04:47 UTC
This package failed to rebuild for FC4 Development around 2005-04-11 after an
automated release bump.

Architectures: i386 ppc

Build failure logs at: http://fedoraproject.org/extras/development/build-logs/

Comment 1 Steve Grubb 2005-04-28 20:59:07 UTC
This appears to be a tool failure. I can't imagine fwbedit needing to link
against librpm. Neither of the other archs link against librpm. Don't know what
to say about this.

Comment 2 Michael Schwendt 2005-05-17 22:07:03 UTC
* Rebuild of libfwbuilder and fwbuilder in the new build system should do [or be
tried at least].

E.g. libfwbuilder is linked against libelf.so.1 from elfutils-libelf, although
it is no build requirement. The unclean build environment of Fedora pre-Extras
could be the cause of qmake adding more/wrong libraries.  libfwbuilder is also
linked against libnetsnmp.so.5, although net-snmp-devel is commented out in the
spec file.

* fwbuilder/libfwbuilder release 2.0.7 is available.

* A few sub-directories are not included in fwbuilder package. Fix is this:

-%{_datadir}/fwbuilder/locale/*
-%{_datadir}/fwbuilder/platform/*
-%{_datadir}/fwbuilder/os/*
+%{_datadir}/fwbuilder/locale/
+%{_datadir}/fwbuilder/platform/
+%{_datadir}/fwbuilder/os/


Comment 3 Michael Schwendt 2005-05-23 17:10:57 UTC
As guessed in comment 2, katzj's all-arch rebuild of libfwbuilder and fwbuilder
succeeded this time.



Note You need to log in before you can comment on or make changes to this bug.