Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1561960 - 'writeback' attribute is missing in 'BlockdevCacheOptions'
Summary: 'writeback' attribute is missing in 'BlockdevCacheOptions'
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Kevin Wolf
QA Contact: CongLi
URL:
Whiteboard:
Depends On:
Blocks: 760547 1558125
TreeView+ depends on / blocked
 
Reported: 2018-03-29 09:18 UTC by Peter Krempa
Modified: 2018-04-03 09:26 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-03 09:26:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Peter Krempa 2018-03-29 09:18:03 UTC
Description of problem:
The legacy cache modes 'none', 'writeback' and 'unsafe' require setting 'cache.writeback' to true, but the QAPI schema does not provide this attribute when adding the image via blockdev/blockdev add.

Version-Release number of selected component (if applicable):
Current upstream git, so downstream versions are affected as well.

How reproducible:
100%

Steps to Reproduce:
1. Look for 'writeback' attribute in  'BlockdevCacheOptions' or the equivalent traversal in the schema returned by 'query-qmp-schema' (blockdev-add->arg-type->cache)

Actual results:
only 'direct' and 'no-flush' attributes are present

Expected results:
'writeback' is present as well.

Additional info:
This is necessary for libvirt to use blockdev-add, since we support all the cache modes as described by this table (taken from qemu-options.hx)

              │ cache.writeback   cache.direct   cache.no-flush                 
 ─────────────┼─────────────────────────────────────────────────                 
 writeback    │ on                off            off                             
 none         │ on                on             off                             
 writethrough │ off               off            off                             
 directsync   │ off               on             off                             
 unsafe       │ on                off            on

Comment 1 Kevin Wolf 2018-04-03 09:26:46 UTC
"cache.writeback" is not a backend option, but a frontend one that can differ between multiple users of a backend (e.g. the guest device needs writethrough, but a block job doesn't). Consequently, it can't be set in -blockdev, but when configuring the users of the node.

The option that you're looking for is write-cache=on|off in -device.


Note You need to log in before you can comment on or make changes to this bug.