Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156193 - SIP registration fails
Summary: SIP registration fails
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: linphone
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ignacio Vazquez-Abrams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-28 12:04 UTC by Tim Waugh
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-04 11:27:14 UTC


Attachments (Terms of Use)
linphone log from 32-bit binary (works) (deleted)
2005-05-03 16:00 UTC, Tim Waugh
no flags Details
linphone log from 64-bit binary (doesn't work) (deleted)
2005-05-03 16:00 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2005-04-28 12:04:56 UTC
Description of problem:
On x86_64, SIP registration fails.  Using a 32-bit binary works fine.  Some
32-bit assumption somewhere.

Version-Release number of selected component (if applicable):
linphone-0.12.2-7
libosip-0.9.7-6

How reproducible:
100%

Steps to Reproduce:
1. Get an account at www.freeworlddialup.com
2. Start linphone, put the accounts settings into linphone
3. Close linphone
4. Start linphone
  
Actual results:
'Unauthorized' appears in the status bar

Expected results:
'Registration successful'

Additional info:
This might be a linphone bug or a libosip bug -- filing under linphone since
that seems to have the most likely looking warnings in the build log.

Comment 1 Ignacio Vazquez-Abrams 2005-04-28 13:30:32 UTC
The settings need to be as follows:

Your sip address: sip:<FWD Number>@fwd.pulver.com
Use sip registrar: Checked
Server address: sip:fwd.pulver.com
Your password: <password>
Address of record: sip:<FWD Number>@fwd.pulver.com

This worked under i386. Does it work under x86_64 as well?

Comment 2 Tim Waugh 2005-04-28 14:02:35 UTC
No, that's the problem.  The native x86_64 linphone says "Unauthorized", but
running a 32-bit one (linked, obviously, to a 32-bit libosip) successfully
registers.  The configuration is the same, since they are run as the same user.

Comment 3 Ignacio Vazquez-Abrams 2005-04-28 14:39:33 UTC
What's the difference between the console output for the two archs using the
same options (sorry, I don't have a x86_64 achine to test on)?

Comment 4 Tim Waugh 2005-05-03 16:00:04 UTC
Created attachment 113973 [details]
linphone log from 32-bit binary (works)

Comment 5 Tim Waugh 2005-05-03 16:00:46 UTC
Created attachment 113974 [details]
linphone log from 64-bit binary (doesn't work)

Comment 6 Ignacio Vazquez-Abrams 2005-05-03 18:11:16 UTC
Okay, it definitely looks like an issue with the hash routines in linphone
0.12.2. Rebuild linphone 1.0.1 from Extras Rawhide and give that a try.

Comment 7 Tim Waugh 2005-05-04 11:09:09 UTC
I grabbed and installed these prebuilt FE development packages:

linphone-1.0.1-2
ortp-0.7.0-2
ortp-devel-0.7.0-2
libosip2-devel-2.2.0-2
libosip2-2.2.0-2

and now registration succeeds.  So does making a call (yay!).

Comment 8 Ignacio Vazquez-Abrams 2005-05-04 11:27:14 UTC
Okay, in that case I'll go ahead and move 1.0.1 to the FC3 branch.


Note You need to log in before you can comment on or make changes to this bug.