Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156184 - Few multi value parameters in iscsi.conf file do not support multiple values
Summary: Few multi value parameters in iscsi.conf file do not support multiple values
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: AJ Lewis
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: 156320
TreeView+ depends on / blocked
 
Reported: 2005-04-28 09:39 UTC by Nitin Chandna
Modified: 2008-04-07 04:42 UTC (History)
3 users (show)

Fixed In Version: RHBA-2005-548
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 19:35:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:548 qe-ready SHIPPED_LIVE iscsi-initiator-utils bug fix 2005-09-28 04:00:00 UTC

Description Nitin Chandna 2005-04-28 09:39:28 UTC
Description of problem:
/etc/iscsi.conf file and man pages mention the following support multiple 
values with comma as separator:
- Subnet/Address
- SLPMulticast
- HostIPsForMP
The first two do not support multiple values and the third one "HostIPsForMP" 
has been misspelt as "HostIPForMP" in /etc/iscsi.conf file.

Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Always

Steps to Reproduce:
1. Configure the above mentioned parameters with multiple values separated by 
comma.
2. When driver is restarted, /var/log/messages shows error on those specific 
lines, where multiple values are used with comma separator.

  
Actual results:
Multiple values for the above mentioned parameters do not function. They have 
to be specified on separate lines to make it work.

Expected results:
Either change the documentation for these parameters to be functioning on 
separate lines or change the implementation to make them work fine as multiple 
values.

Additional info:
None

Comment 3 AJ Lewis 2005-06-14 19:33:11 UTC
I'm not seeing anywhere that Subnet/Address is said to support multiple values

Comment 4 AJ Lewis 2005-06-14 19:39:45 UTC
Ok, so i put multiple values into the SLPMulticast line, and i got no errors. 
What version are you using?  Are you using the RPM?

Comment 5 Nitin Chandna 2005-06-15 07:20:35 UTC
1. Version of iSCSI Initiator: 3.6.2 downloaded from www.sf.net iscsi initiator
page. This was a .gz file dowaloaded from the sf.net
2. This was not available as rpm.
3. This was tested on a 2.4 kernel: kernel-2.4.20-8 (This was installed from a CD)
4. The man page of /etc/iscsi.conf, specifies usage of multiple values for the
mentioned attributes. 
5. SLPMulticast worked with value "all", but not with comma separated value.
/var/log/messages showed error at the line specified, since it was not able to
parse the multiple values with comma separators.

Comment 6 AJ Lewis 2005-06-15 13:33:57 UTC
Well, I'm running RHEL3-U5 w/the iscsi-initiator-utils-3.6.2-7 package - i add
"SLPMulticast=192.168.22.112,10.15.80.2" to my /etc/iscsi.conf and start iscsi.
 /var/log/messages has this:

Jun 15 08:32:09 bench-05 kernel: iSCSI: 3.6.1 (22-Sep-2004) built for Linux
2.4.21-32.0.1.ELsmp
Jun 15 08:32:09 bench-05 kernel: iSCSI: will translate deferred sense to current
sense on disk command responses
Jun 15 08:32:09 bench-05 kernel: iSCSI: control device major number 254
Jun 15 08:32:09 bench-05 kernel: iSCSI: allocating task cache iscsi_0007304628
with reaping disabled
Jun 15 08:32:09 bench-05 kernel: iSCSI: detected HBA ddc16b00, host #0
Jun 15 08:32:09 bench-05 kernel: scsi0 : iSCSI 3.6.1 (22-Sep-2004)
Jun 15 08:32:09 bench-05 iscsid[9845]: version 3.6.2 (27-Sep-2004)
Jun 15 08:32:09 bench-05 iscsid[9845]: INBP boot check returned
this_is_inbp_boot = 0
Jun 15 08:32:09 bench-05 iscsid[9848]: Connected to Discovery Address 10.15.84.19
Jun 15 08:32:29 bench-05 iscsi:  succeeded

There is no mention of an error in the config file.  Please update to the latest
RHEL3 codebase and try again (and use the iscsi-initiator-utils rpm)

Comment 7 Nitin Chandna 2005-06-16 12:02:21 UTC
I just re-tried, and saw there were no errors when I specified comma-separated
multiple values for SLPMulticast, but the devices were not shown after executing
iscsi-ls -l. Whereas when SLPMulticast was given a value "all", the devices were
visible on the host with iscsi-ls -l.

From where can I download RHEL3-U5 and iscsi-initiator-utils-3.6.2-7 package? I
will try to test this defect against this combination.

Comment 8 Tom Coughlan 2005-06-16 12:50:34 UTC
> From where can I download RHEL3-U5 ...

It is on RHN. You should have an entitlement. If not please contact Rob Kenna
(rkenna@redhat.com). 

Comment 10 AJ Lewis 2005-06-21 18:19:12 UTC
I'm seeing the same thing as comment #7 with the current RPM - I'll pull the
SLPMulticast comma separated options out of the configs and man pages.

Comment 15 AJ Lewis 2005-06-23 16:08:48 UTC
Fixes to documentation have been committed upstream - will be picked up in next
RPM build.

Comment 18 Red Hat Bugzilla 2005-09-28 19:35:21 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-548.html



Note You need to log in before you can comment on or make changes to this bug.