Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156182 - Details of ActiveTimeout not given in man page and iscsi.conf file
Summary: Details of ActiveTimeout not given in man page and iscsi.conf file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: AJ Lewis
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: 156320
TreeView+ depends on / blocked
 
Reported: 2005-04-28 09:03 UTC by Nitin Chandna
Modified: 2008-04-07 04:42 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-548
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 19:35:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:548 qe-ready SHIPPED_LIVE iscsi-initiator-utils bug fix 2005-09-28 04:00:00 UTC

Description Nitin Chandna 2005-04-28 09:03:08 UTC
Description of problem:
ACTIVE TIMEOUT is not mentioned in /etc/iscsi.conf file and man page 
for /etc/iscsi.conf. But is displayed with iscsi-ls -c.

Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Always

Steps to Reproduce:
1. Configure a target (JBOD) on MDS 9216
2. Configure the DiscoveryAddress on the linux host and start the driver
3. Execute iscsi-ls -c and details of ACTIVE TIMEOUT is shown.
  
Actual results:
Executing iscsi-ls -c shows details of ACTIVE TIMEOUT. man pages 
and /etc/iscsi.conf does not mention anything about Active Timeout.

Expected results:
Either man pages and /etc/iscsi.conf should mention details about Active 
timeout or if it is not being used, it should be removed from the code and 
should not be displayed in iscsi-ls -c

Additional info:
The output of iscsi-ls -c looks like follows:

*******************************************************************************
[root@linux-2 root]# iscsi-ls -c
*******************************************************************************
        SFNet iSCSI Driver Version ... 3.6.2 (27-Sep-2004 )
*******************************************************************************
TARGET NAME             : iqn.2004-04.com.cisco.cnitin-jbod-567c
TARGET ALIAS            : 
HOST NO                 : 2 
BUS NO                  : 0 
TARGET ID               : 4 
TARGET ADDRESS          : 10.1.1.80:3260
SESSION STATUS          : ESTABLISHED AT Thu Apr 28 19:45:32 2005
NO. OF PORTALS          : 1 
PORTAL ADDRESS 1        : 10.1.1.80:3260,12416
SESSION ID              : ISID 00023d000001 TSID 3080

TARGET CONFIGURATION KEYS :
------------------------- 
INITIAL R2T             : No
IMMEDIATE DATA          : Yes
HEADERDIGEST            : NONE
DATA DIGEST             : NONE
FIRSTBURSTLENGTH        : 65536
MAXBURSTLENGTH          : 262144
MAXRECVDATASEGMENTLENGTH: initiator - 131072
                          target    - 1344
LOGIN TIMEOUT           : 10
AUTH TIMEOUT            : 30
ACTIVE TIMEOUT          : 5
IDLE TIMEOUT            : 10
PING TIMEOUT            : 3
*******************************************************************************

Comment 1 Smitha Narayanaswamy 2005-05-11 13:47:39 UTC
This bug has been filed on Sourceforge and has been closed there:
[ 1110710 ] iscsi-ls -c shows Active Timeout without any mention in docs

Comment 7 AJ Lewis 2005-06-23 15:09:41 UTC
Verified documentation change upstream

Comment 8 Red Hat Bugzilla 2005-09-28 19:35:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-548.html



Note You need to log in before you can comment on or make changes to this bug.