Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156178 - jwhois.conf needs updating for new Afrinic registry
Summary: jwhois.conf needs updating for new Afrinic registry
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: jwhois
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
: 156350 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-28 08:35 UTC by Chris Jones
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 3.2.2-14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-30 17:47:59 UTC


Attachments (Terms of Use)

Description Chris Jones 2005-04-28 08:35:46 UTC
Description of problem:
There is no reference in /etc/jwhois.conf for the new Afrinic registry

Version-Release number of selected component (if applicable):
3.2.2-6.FC3.1

How reproducible:
Every time

Steps to Reproduce:
1. whois 82.101.166.146
  
Actual results:
produces a default report from RIPE explaining that the whois record is now
maintained by whois.afrinic.net

Expected results:
I would expect to see the details of the registered customer of Afrinic for the
IP address queried

Actual Output:
[root@bilbo log]# whois 82.101.166.146
[Querying whois.ripe.net]
[whois.ripe.net]
% This is the RIPE Whois query server #2.
% The objects are in RPSL format.
%
% Note: the default output of the RIPE Whois server
% is going to be changed soon. Your tools may need
% to be adjusted. See
% http://www.ripe.net/db/news/abuse-proposal-20050331.html
% for more details.
%
% Rights restricted by copyright.
% See http://www.ripe.net/db/copyright.html

inetnum:      82.101.128.0 - 82.101.191.255
org:          ORG-AFNC1-RIPE
netname:      AFRINIC-NET-TRANSFERRED-20050223
descr:        This network has been transferred to AFRINIC
remarks:      These IP addresses are assigned in the AFRINIC region.
remarks:      Authoritative registration information for this network
remarks:      is available for query and modification in
remarks:      the AFRINIC whois database: whois.afrinic.net or
remarks:      web site: http://www.afrinic.net
remarks:      The routing registry information (route(6) objects)
remarks:      may be published in any Routing Registry, including
remarks:      RIPE Whois Database
country:      EU # country is really somewhere in African Region
admin-c:      AFRI-RIPE
tech-c:       AFRI-RIPE
status:       ALLOCATED PA
mnt-by:       RIPE-NCC-HM-MNT
mnt-routes:   RIPE-NCC-RPSL-MNT
changed:      hostmaster@ripe.net 20050223
source:       RIPE

organisation: ORG-AFNC1-RIPE
org-name:     African Internet Numbers Registry
org-type:     RIR
address:      see http://www.afrinic.net
e-mail:       bitbucket@ripe.net
admin-c:      AFRI-RIPE
tech-c:       AFRI-RIPE
remarks:      For more information on AFRINIC assigned blocks, use
remarks:      AFRINIC's whois database, whois.afrinic.net.
mnt-ref:      RIPE-NCC-HM-MNT
mnt-by:       RIPE-NCC-HM-MNT
changed:      bitbucket@ripe.net 20050223
source:       RIPE

role:         The African Internet Numbers Registry
org:          ORG-AFNC1-RIPE
address:      AFRINIC, see http://www.afrinic.net
admin-c:      AFRI-RIPE
tech-c:       AFRI-RIPE
nic-hdl:      AFRI-RIPE
e-mail:       bitbucket@ripe.net
remarks:      For more information on AFRINIC assigned blocks, connect
remarks:      to AFRINIC's whois database, whois.afrinic.net.
mnt-by:       RIPE-NCC-HM-MNT
changed:      hostmaster@ripe.net 20050223
source:       RIPE


[root@bilbo log]#

Comment 1 Miloslav Trmač 2005-04-29 13:10:38 UTC
*** Bug 156350 has been marked as a duplicate of this bug. ***

Comment 2 Miloslav Trmač 2005-04-30 17:47:59 UTC
Unfortunately I can't find a single authoritative list of all
address ranges now managed by AfriNIC, so I have added only this
single range to rawhide jwhois-3.2.2-14.

Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.