Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156175 - Logwatch reports Passed e-mails from amavisd-new as unmatched entries
Summary: Logwatch reports Passed e-mails from amavisd-new as unmatched entries
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: logwatch
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-28 08:03 UTC by Dennis Wagelaar
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-29 09:01:13 UTC


Attachments (Terms of Use)
Patch to /etc/log.d/scripts/services/amavis script (deleted)
2005-04-28 08:05 UTC, Dennis Wagelaar
no flags Details | Diff

Description Dennis Wagelaar 2005-04-28 08:03:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
Since there is no Redhat amavis rpm, I am using a third party amavis package: amavisd-new-2.2.1-1.1.fc3.rf from http://apt.sw.be/fedora/$releasever/en/$basearch/dag

Recently, this amavis package changed its logging behaviour to no longer put commas behind the "Passed" log entries. The logwatch /etc/log.d/scripts/services/amavis script however only ignores "/^Passed, /" entries. I've changed this into "/^Passed /" and things worked again (line 63).

That was in the previous version of logwatch and after yesterday's yum update, the old bug was reintroduced. I've decided it's better to solve the problem at the source, so here I am ;-).

Version-Release number of selected component (if applicable):
logwatch-5.2.2-1.FC3.1

How reproducible:
Always

Steps to Reproduce:
1. wait for logwatch e-mail to come in ;-)
2.
3.
  

Actual Results:  see lot's of entries with "Passed" under **Unmatched Entries**.

Expected Results:  see only non-Passed messages.

Additional info:

Comment 1 Dennis Wagelaar 2005-04-28 08:05:29 UTC
Created attachment 113759 [details]
Patch to /etc/log.d/scripts/services/amavis script

line 63 is changed from "/^Passed, /" to "/^Passed /"

Comment 2 Ivana Varekova 2005-06-29 09:01:13 UTC
This bug is fixed in the current fc version (logwatch-6.1.2-1).


Note You need to log in before you can comment on or make changes to this bug.