Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156167 - hotplug events in wrong order
Summary: hotplug events in wrong order
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 157137 157155 157618 158409 158482 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-28 03:35 UTC by David Zeuthen
Modified: 2015-01-04 22:19 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 17:02:52 UTC


Attachments (Terms of Use)
a full output of 'lshal' with 'USB-FDU' attached (deleted)
2005-05-07 20:39 UTC, Michal Jaegermann
no flags Details
'lsusb' view of the device in question (deleted)
2005-05-07 20:41 UTC, Michal Jaegermann
no flags Details

Description David Zeuthen 2005-04-28 03:35:33 UTC
Description of problem:

Described here

 http://marc.theaimsgroup.com/?l=linux-usb-devel&m=111463358121981&w=2

Version-Release number of selected component (if applicable):


2.6.11-1.1268_FC4. Probably since upstream 2.6.12-rc3.

How reproducible:

Always

Steps to Reproduce:

See link

Additional info:

This bug means that hal will identify USB storage devices as proper SCSI devices
resulting in that we won't automount/add /etc/fstab entry entries.

Upstream appear to be working on a fix. Please include this for FC4.

Comment 1 David Zeuthen 2005-04-28 03:37:41 UTC
Adding to FC4 blocker since not automounting USB gizmos is a pretty severe
regression.

Comment 2 Bastien Nocera 2005-05-06 15:04:00 UTC
Also causes serial interfaces of my Palm to show up as children of the USB
controller instead of children of the Palm device.
Also affects RHEL4.

Comment 3 Michal Jaegermann 2005-05-07 20:39:38 UTC
Created attachment 114127 [details]
a full output of 'lshal' with 'USB-FDU' attached

> I've also changed version from 'fc3' to 'devel' since hal 0.5.1 is
> not in fc3.

Sorry, this was supposed to be devel and not fc3.  I forgot to switch
distribution tag.

> On what kernel does this happen,

At least on these:

2.6.11-1.1287_FC4
2.6.11-1.1286_FC4
2.6.11-1.1284_FC4

>  try one that is pre 2.6.12-rc3

Hm, I do not have a supply of kernels going that far back.

> (this one looks like a duplicate of bug 156167).

Possibly, although not recognized floppy device may, or may not, be
the same thing.

> Also, please try to attach the output of lshal.

OK. 'lsusb' does recognize the device properly.

Comment 4 Michal Jaegermann 2005-05-07 20:41:04 UTC
Created attachment 114128 [details]
'lsusb' view of the device in question

Comment 5 Michal Jaegermann 2005-05-07 20:44:58 UTC
Sigh! Not my day! Attachments were really meant for bug 157155 but
these two bugs seem to be possibly related or even duplicates.

Comment 6 David Zeuthen 2005-05-07 22:04:40 UTC
*** Bug 157155 has been marked as a duplicate of this bug. ***

Comment 7 David Zeuthen 2005-05-10 16:23:55 UTC
Not sure comment 2 is correct - I think this is another bug.

Comment 8 David Zeuthen 2005-05-10 21:32:20 UTC
*** Bug 157137 has been marked as a duplicate of this bug. ***

Comment 9 David Zeuthen 2005-05-13 09:52:02 UTC
*** Bug 157618 has been marked as a duplicate of this bug. ***

Comment 10 David Zeuthen 2005-05-21 20:45:08 UTC
Kay Sievers posted a patch to the LKML to fix this

 http://lkml.org/lkml/2005/5/19/146

Please apply.

Comment 11 David Zeuthen 2005-05-22 00:57:39 UTC
*** Bug 158409 has been marked as a duplicate of this bug. ***

Comment 12 Dave Jones 2005-05-22 04:45:02 UTC
latest builds should have this fixed.


Comment 13 Michal Jaegermann 2005-05-22 20:42:23 UTC
> latest builds should have this fixed.
Maybe.  I am not sure.  See bug 158482.


Comment 14 David Zeuthen 2005-05-22 21:39:50 UTC
*** Bug 158482 has been marked as a duplicate of this bug. ***

Comment 15 David Zeuthen 2005-05-22 22:01:53 UTC
So, bug 158482 suggests this issue still persists. I can verify the bug is still
here with the latest Rawhide kernel

[root@daxter ~]# uname -a
Linux daxter.boston.redhat.com 2.6.11-1.1329_FC4 #1 Thu May 19 21:14:20 EDT 2005
i686 i686 i386 GNU/Linux

Dave, did the 1329 build include the fix? I guess not as it was built Thu 19 May
2005 10:25:43 PM EDT. Moving back to ASSIGNED until we can test this :-)



Comment 16 David Zeuthen 2005-05-22 22:06:33 UTC
Btw, the kernel-2.6.spec file suggests this is fixed in builds 1334 or later so
I guess we just have to wait for these to be pushed to Rawhide

 * Sat May 21 2005 Dave Jones <davej@redhat.com> [2.6.11-1.1334_FC4]
 - driver core: restore event order for device_add()


Comment 17 Warren Togami 2005-05-23 03:09:30 UTC
1340 was pushed to rawhide, it should be in tomorrow's mirror tree.

Comment 18 David Zeuthen 2005-05-23 17:02:52 UTC
1340 works perfectly for me (tried hotplugging my iPod Mini and a USB1.1 CF
Reader several times). So, I'm closing this bug.


Note You need to log in before you can comment on or make changes to this bug.