Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156166 - i386 binaries cause segmentation fault on x86_64
Summary: i386 binaries cause segmentation fault on x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 155790
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
: 155810 156268 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-28 03:14 UTC by Jeff Sheltren
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-29 00:58:55 UTC


Attachments (Terms of Use)
dmesg output (deleted)
2005-04-28 03:15 UTC, Jeff Sheltren
no flags Details

Description Jeff Sheltren 2005-04-28 03:14:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
Trying to run any (that I've tested) binary compiled for i386 causes a segmentation fault on x86_64 machine.  ldd does not work, nor am I able to generate core files from the seg fault - when 'ulimit -c' is increased, there is a kernel oops when trying to write out the core file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile program on i386 (or use Fedora's firefox.i386 rpm for example)
2. Run binary
3.
  

Actual Results:  Segmentation Fault.

Expected Results:  Program should run as normal.

Additional info:

For example, I have compiled a simple 'hello world' program on i386 machine (forsberg):
[jeff@forsberg testcode]$ cat hello.c
#include <stdio.h>

main() {
    printf("Hi there.\n");
}
[jeff@forsberg testcode]$ gcc hello.c -o hello
[jeff@forsberg testcode]$ ./hello
Hi there.
[jeff@forsberg testcode]$ ldd hello
        libc.so.6 => /lib/libc.so.6 (0x00759000)
        /lib/ld-linux.so.2 (0x0073c000)

Running the same program on an Intel x86_64 machine (hell) causes a segfault:
[jeff@hell testcode]$ ./hello
Segmentation fault
[jeff@hell testcode]$ ldd hello
/usr/bin/ldd: line 116:  5447 Segmentation fault      LD_TRACE_LOADED_OBJECTS=1 LD_WARN= LD_BIND_NOW= LD_LIBRARY_VERSION=$verify_out LD_VERBOSE= "$@"
[jeff@hell ~]$ ulimit -c unlimited
[jeff@hell testcode]$ ./hello
Segmentation fault

Message from syslogd@hell at Wed Apr 27 20:12:48 2005 ...
hell kernel: Oops: 0000 [5] SMP 

Message from syslogd@hell at Wed Apr 27 20:12:48 2005 ...
hell kernel: CR2: 00000000ffffe02c

This effects multiple fedora RPMs including firefox, for example.

I will attach dmesg output showing crashes for both firefox and above 'hello' example.

Comment 1 Jeff Sheltren 2005-04-28 03:15:56 UTC
Created attachment 113756 [details]
dmesg output

Comment 2 Sylvain Rouillard 2005-04-28 11:06:24 UTC
This bug is most certainly related with bug 155810, which was initially dealing
only with OOo.

Comment 3 Caolan McNamara 2005-04-28 11:07:26 UTC
*** Bug 155810 has been marked as a duplicate of this bug. ***

Comment 4 Sylvain Rouillard 2005-04-28 11:17:12 UTC
And here is what I get when trying to start oowriter (or any OOo app):

Apr 28 13:15:19 localhost kernel: javaldx[9723]: segfault at 00000000ffffe01c
rip 0000000000a72575 rsp 00000000ffffb8dc error 4
Apr 28 13:15:19 localhost kernel: pagein[9724]: segfault at 00000000ffffe01c rip
0000000000a72575 rsp 00000000ffffb7cc error 4
Apr 28 13:15:19 localhost kernel: soffice.bin[9725]: segfault at
00000000ffffe01c rip 0000000000a72575 rsp 00000000ffffcf6c error 4

I hope that helps.

Comment 5 Marco 2005-04-28 14:23:36 UTC
Confirmed also for kernel 1275-x86_64

Comment 6 Warren Togami 2005-04-28 15:47:20 UTC
*** Bug 156268 has been marked as a duplicate of this bug. ***

Comment 7 Gene Czarcinski 2005-04-28 15:56:46 UTC
with 1275 x86_64 kernel, I get the following for openoffice:

[gc@hummer ~]$ openoffice.org-1.9
/usr/lib/openoffice.org1.9.96/program/soffice: line 230:  4151 Segmentation
fault      "${sd_prog}"/pagein -L"${sd_prog}" ${sd_pagein_args}
/usr/lib/openoffice.org1.9.96/program/soffice: line 241:  4152 Segmentation
fault      "$sd_prog/$sd_binary" "$@"

dmesg:

javaldx[4254]: segfault at 00000000ffffe01c rip 000000000027f575 rsp
00000000ffffc42c error 4
pagein[4255]: segfault at 00000000ffffe01c rip 000000000027f575 rsp
00000000ffffc2ac error 4
soffice.bin[4256]: segfault at 00000000ffffe01c rip 000000000027f575 rsp
00000000ffffbb9c error 4

Comment 8 Sylvain Rouillard 2005-04-28 16:36:18 UTC
BTW, this looks very similar to Bug 155790 too...

Comment 9 Dave Jones 2005-04-29 00:58:55 UTC

*** This bug has been marked as a duplicate of 155790 ***

Comment 10 Warren Togami 2005-04-29 06:21:24 UTC
Roland's fix checked into CVS seems to work for me.



Note You need to log in before you can comment on or make changes to this bug.