Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156163 - init=/usr/bin/gdb breaks the kernel
Summary: init=/usr/bin/gdb breaks the kernel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-28 02:04 UTC by Bill Nottingham
Modified: 2014-03-17 02:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-01 04:40:56 UTC


Attachments (Terms of Use)
The oops, captured via netsyslog. Sorry about the formatting. (deleted)
2005-04-28 02:04 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2005-04-28 02:04:52 UTC
Description of problem:

Running with init=/usr/bin/gdb oopses the kernel

Version-Release number of selected component (if applicable):

2.6.11-1.1275_FC4

How reproducible:

Every time

Steps to Reproduce:
1. boot with init=/usr/bin/gdb
2. <gdb> file /sbin/init
3. <gdb> set args 3
4. <gdb> run

Actual results:

*BANG*

Expected results:

Well, not that

Additional info:

I hate debugging init.

Comment 1 Bill Nottingham 2005-04-28 02:04:53 UTC
Created attachment 113755 [details]
The oops, captured via netsyslog. Sorry about the formatting.

Comment 2 Dave Jones 2005-12-28 04:57:33 UTC
when I try to reproduce this now, I get different failures, that look to be
because we don't have /dev/initctl

It smells a bit odd to me, but I don't think it's a kernel bug. reassign to
mkinitrd ?


Comment 3 Bill Nottingham 2006-01-01 04:40:56 UTC
The kernel has probably long since been fixed. I'll just close it.


Note You need to log in before you can comment on or make changes to this bug.