Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156157 - xen create causes kernel panic due to paging request
Summary: xen create causes kernel panic due to paging request
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xen
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 23:55 UTC by Jacob Leaver
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 18:00:13 UTC


Attachments (Terms of Use)

Description Jacob Leaver 2005-04-27 23:55:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
Running fedora-devel, with the 1268 build kernel, on an a dual processor dell poweredge 2650, I can boot up the xen0 kernel, and start xend, but when I try to start the first xenU instance, I get a kernel panic and xm create hangs. Logs are show below.   I can provide additional information as required.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot Xen0
2. run xend
3. xm create
  

Actual Results:  Apr 27 16:26:39 virt01 kernel: Unable to handle kernel paging request at virtual address 8b04ec93
Apr 27 16:26:39 virt01 kernel:  printing eip:
Apr 27 16:26:39 virt01 kernel: c01503ed
Apr 27 16:26:39 virt01 kernel: *pde = ma 00000000 pa 55555000
Apr 27 16:26:39 virt01 kernel:  [<c015a3a5>] unmap_page_range+0x85/0xc0
Apr 27 16:26:39 virt01 kernel:  [<c015a5a3>] unmap_vmas+0x1c3/0x290
Apr 27 16:26:39 virt01 kernel:  [<c015f6a5>] unmap_region+0xb5/0x170
Apr 27 16:26:39 virt01 kernel:  [<c015fa37>] do_munmap+0x107/0x150
Apr 27 16:26:39 virt01 kernel:  [<c015fada>] sys_munmap+0x5a/0x80
Apr 27 16:26:39 virt01 kernel:  [<c0109493>] syscall_call+0x7/0xb
Apr 27 16:26:39 virt01 kernel: Oops: 0000 [#1]
Apr 27 16:26:39 virt01 kernel: SMP 
Apr 27 16:26:39 virt01 kernel: Modules linked in: bridge md5 ipv6 parport_pc lp parport autofs4 sunrpc ipt_REJECT ipt_state ip_conntrack iptable_filter ip_tables dm_mod ohci_hcd serial_core cfi_probe gen_probe scb2_flash mtdcore chipreg map_funcs tg3 ext3 jbd aacraid sd_mod scsi_mod
Apr 27 16:26:39 virt01 kernel: CPU:    1
Apr 27 16:26:39 virt01 kernel: EIP:    0061:[<c01503ed>]    Not tainted VLI
Apr 27 16:26:39 virt01 kernel: EFLAGS: 00010282   (2.6.11-1.1268_FC4xen0) 
Apr 27 16:26:39 virt01 kernel: EIP is at set_page_dirty+0x1d/0x60
Apr 27 16:26:39 virt01 kernel: eax: 8b04ec83   ebx: c10f7d60   ecx: c10f7d60   edx: c025e140
Apr 27 16:26:39 virt01 kernel: esi: c78a1d44   edi: 00feb067   ebp: b7751000   esp: c616febc
Apr 27 16:26:39 virt01 kernel: ds: 007b   es: 007b   ss: 0069
Apr 27 16:26:39 virt01 kernel: Process python (pid: 2240, threadinfo=c616e000 task=c3de8a80)
Apr 27 16:26:39 virt01 kernel: Stack: c34a9224 c015a247 00000000 00000000 c511ab74 b7752000 b7752000 b7751fff 
Apr 27 16:26:39 virt01 kernel:        c015a3a5 c110af00 c511ab74 b7751000 b7752000 00000000 00001000 b7752000 
Apr 27 16:26:39 virt01 kernel:        c36df198 b7752000 c015a5a3 c110af00 c36df198 b7751000 b7752000 00000000 
Apr 27 16:26:39 virt01 kernel: Call Trace:
Apr 27 16:26:39 virt01 kernel:  [<c015a247>] zap_pte_range+0x1a7/0x280
Apr 27 16:26:39 virt01 kernel:  [<c015a3a5>] unmap_page_range+0x85/0xc0
Apr 27 16:26:39 virt01 kernel:  [<c015a5a3>] unmap_vmas+0x1c3/0x290
Apr 27 16:26:39 virt01 kernel:  [<c015f6a5>] unmap_region+0xb5/0x170
Apr 27 16:26:39 virt01 kernel:  [<c015fa37>] do_munmap+0x107/0x150
Apr 27 16:26:39 virt01 kernel:  [<c015fada>] sys_munmap+0x5a/0x80
Apr 27 16:26:39 virt01 kernel:  [<c0109493>] syscall_call+0x7/0xb
Apr 27 16:26:39 virt01 kernel: Code: ff ff 8d b6 00 00 00 00 8d bf 00 00 00 00 83 ec 04 89 c1 8b 50 10 8b 00 a9 00 00 01 00 75 3e f6 c2 01 75 28 85 d2 74 24 8b 42 40 <8b> 40 10 85 c0 74 0c 89 0c 24 ff d0 89 c2 89 d0 5a c3 90 89 0c 

Expected Results:  The xenU instance should have initialized.

Additional info:

Comment 1 Rik van Riel 2005-04-28 00:34:33 UTC
A fix for this was checked in this morning, and is in kernel-2.6.11-1.1275_FC4

Comment 2 Jacob Leaver 2005-04-28 18:00:13 UTC
   (In reply to comment #1)
> A fix for this was checked in this morning, and is in kernel-2.6.11-1.1275_FC4

Build 1275 does indeed resolve this issue.  Many thanks for all the hard work. 
Is there somewhere specific that I should be tracking/participating fedora/xen
related issues, advancements, etc?


Comment 3 Rik van Riel 2005-04-28 19:00:26 UTC
Since Xen is still in development, I try to do as much as possible in the Xen
community, and as little as possible in the Fedora RPM. This means that the
xen-devel@lists.xensource.com mailing list would be the best place to track Xen
for now. 


Note You need to log in before you can comment on or make changes to this bug.