Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156144 - Unable to load dynamic library '/usr/lib/php4/snmp.so' - /usr/lib/php4/snmp.so: undefined symbol: usmAES192PrivProtocol
Summary: Unable to load dynamic library '/usr/lib/php4/snmp.so' - /usr/lib/php4/snmp.s...
Keywords:
Status: CLOSED DUPLICATE of bug 155975
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 20:48 UTC by Marcin Szweda
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-27 21:19:28 UTC


Attachments (Terms of Use)

Description Marcin Szweda 2005-04-27 20:48:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
PHP4* and PHP5* (including the latest releases AND CVS checkouts) do NOT
compile on a system with Net-SNMP 5.2*.

This is because Net-SNMP has become more standards-compliant and got rid
of some AES192/AES256 stuff they had.

Note the removal of the following symbols:
usmAES192PrivProtocol
usmAES256PrivProtocol

PHP uses the above 2 symbols.


Version-Release number of selected component (if applicable):
net-snmp-5.2.1-10.FC3, php-snmp-4.3.11-2.4

How reproducible:
Always

Steps to Reproduce:
1. Install net-snmp-5.2.1-10.FC3
2. Install php-snmp-4.3.11-2.4
3. Run php (i.e. from command line)
  

Actual Results:  PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/snmp.so' - /usr/lib/php4/snmp.so: undefined symbol: usmAES192PrivProtocol in Unknown on line 0

Expected Results:  Working SNMP module.

Additional info:

Comment 1 Joe Orton 2005-04-27 21:19:28 UTC

*** This bug has been marked as a duplicate of 155975 ***


Note You need to log in before you can comment on or make changes to this bug.