Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156131 - yum update results in python NameError (too many packages?)
Summary: yum update results in python NameError (too many packages?)
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 19:36 UTC by Paul Dickson
Modified: 2014-01-21 22:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-27 20:21:26 UTC


Attachments (Terms of Use)

Description Paul Dickson 2005-04-27 19:36:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
Running "yum update" to update fc4-test2 this morning resulted in the error:

NameError: global name 'yum' is not defined

Reducing the total number of packages to less than 50 allowed a successful
install of all packages.

Version-Release number of selected component (if applicable):
yum-2.3.2-1

How reproducible:
Always

Steps to Reproduce:
1. yum update

To reduce the list of packages, I used commands similar to "yum update 'e*'".

Actual Results:  The test transaction succeeded, the real transactions failed before starting.

Expected Results:  Packages being installed.

Additional info:

Trimmed output from error:

(90/96): xorg-x11-doc-6.8 100% |=========================| 5.0 MB    00:10
(91/96): xorg-x11-twm-6.8 100% |=========================| 156 kB    00:00
(92/96): vim-enhanced-6.3 100% |=========================| 1.0 MB    00:02
(93/96): libselinux-1.23. 100% |=========================|  64 kB    00:00
(94/96): gnome-applets-2. 100% |=========================| 7.1 MB    00:14
(95/96): system-config-la 100% |=========================|  50 kB    00:00
(96/96): system-config-ki 100% |=========================| 951 kB    00:01
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Traceback (most recent call last):
  File "/usr/bin/yum", line 15, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 149, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 651, in doTransaction
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.4/site-packages/PIL/__init__.py", line 333, in runTransaction

NameError: global name 'yum' is not defined
[root@white 11:51:27 ~]# 


Subsets of the entire set of packages have install successfully.  I'll
continue whittling down the list until the entire list installs or a bad
package is found. (will finish before submitting this bug report)

Once there was only 49 packages remaining, yum update installed without
problems.

512MB RAM, only 28KB swapped (yes, KB).

Comment 1 Jeremy Katz 2005-04-27 20:21:26 UTC
Caused by a silly namespace problem already fixed in upstream CVS and will be in
2.3.3.  The root cause is likely that you didn't have enough space on / for all
of the updates.


Note You need to log in before you can comment on or make changes to this bug.