Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156117 - shutdown.allow and ca in inittab.
Summary: shutdown.allow and ca in inittab.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 17:31 UTC by Prakash Purushotham
Modified: 2014-03-17 02:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-03 21:01:36 UTC


Attachments (Terms of Use)

Description Prakash Purushotham 2005-04-27 17:31:24 UTC
Description of problem:

I have added the "-a" flag to the shutdown command on the ca (Ctrl-Alt-Del)
controls in inittab. I have also created the shutdown.allow file in /etc and
added root and a couple of other users who can hit Ctrl-Alt-Del to reboot the
system.

When no (super)users are logged in, hitting Ctrl-Alt-Del functions normally,
that is, it displays "shutdown: no authorized users logged in". This behaviour
is exhibited in all earlier versions (RH7 to FC2).

When root or any of the authorized users are logged in to one terminal (say
tty1) and the user Ctrl-Alt-Fn's to another terminal ( say tty 4) and hits
Ctrl-Alt-Del without logging in, FC3 initiates the reboot sequence. RH7 - FC2 do
not initiate a reboot.

Is this a bug in FC3 or was it a bug in the previous versions?

Version-Release number of selected component (if applicable):
Fedora Core 3, all patches current.

How reproducible:
Very much reproducible

Steps to Reproduce:
1. Add the -a flag to shutdown command on the ca line in /etc/inittab
2. init Q
3. create /etc/shutdown.allow and add root.
3. switch to another terminal, say Ctrl-Alt-F3 (tty3)
4. do not log in here
5. Hit Ctrl-Alt-Del
6. System reboots
  
Actual results:

Ctrl-Alt-Del initiates reboot if authorized user is logged in on another terminal.

Expected results:

should display "Shutdown: no authorized users logged in"

Additional info:

Comment 1 Bill Nottingham 2005-10-03 21:01:36 UTC
It looks like the code is working as designed, in that it checks all the logged
in users on all virtual terminals.


Note You need to log in before you can comment on or make changes to this bug.