Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156116 - updating xml-commons-apis removes sun's jre package
Summary: updating xml-commons-apis removes sun's jre package
Keywords:
Status: CLOSED DUPLICATE of bug 157151
Alias: None
Product: Fedora
Classification: Fedora
Component: xml-commons
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Frank Ch. Eigler
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 17:26 UTC by Jef Spaleta
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 00:56:10 UTC


Attachments (Terms of Use)
log of rpm -Uvh -vv of xml-commons-* packages showing jre package removal (deleted)
2005-04-27 17:26 UTC, Jef Spaleta
no flags Details

Description Jef Spaleta 2005-04-27 17:26:42 UTC
Filed on request of Thomas Fitzsimmons

Description of problem:
xml-commonas-apis when updated with rpm or yum ends up removing sun's jre
package from the system.  

Specific scenario that I have tested and can reproduce:
start with  Sun's jre-1.5.0_02-fcs installed
  and xml-commons*-1.0-0.b2.6jpp_7fc installed
update to xml-commons*-1.0-0.b2.6jpp_9fc via rpm or yum 
  jre package is removed from the system

Attached you'll find a log from one rpm -Uvh attempt:

rpm -Uvh -vv xml-commons-apis-1.0-0.b2.6jpp_9fc.noarch.rpm
xml-commons-1.0-0.b2.6jpp_9fc.noarch.rpm
xml-commons-which-1.0-0.b2.6jpp_9fc.noarch.rpm  2>
/tmp/rpm-xml-commons-install.log

How reproducible:
I can reproduce this with set of packages detailed above on demand.
I have not tested the latest set of xml-commons-* packages yet.
I have personally only tested on i686 system.

Comment 1 Jef Spaleta 2005-04-27 17:26:43 UTC
Created attachment 113725 [details]
log of rpm -Uvh -vv of xml-commons-*  packages showing jre package removal

Comment 2 Gary Benson 2005-04-28 08:53:33 UTC
Does anyone have even the slightest idea why this should be the case?

Comment 3 Jeremy Katz 2005-05-19 00:56:10 UTC

*** This bug has been marked as a duplicate of 157151 ***


Note You need to log in before you can comment on or make changes to this bug.