Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156095 - Programs can't import the gst module
Summary: Programs can't import the gst module
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer-python
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Vander Stichele
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 156096 156214 156215 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 14:57 UTC by Jacob Kroon
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-01 21:26:05 UTC


Attachments (Terms of Use)

Description Jacob Kroon 2005-04-27 14:57:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
The rpm installs files into /usr/lib/python2.3, although since Fedora Core 4 uses python 2.4 they should perhaps be installed into /usr/lib/python2.4.

Applications that try to import the gst module will fail:

ImportError: No module named gst

Version-Release number of selected component (if applicable):
gstreamer-python-0.8.1-1

How reproducible:
Always

Steps to Reproduce:
(null)

Additional info:

Comment 1 Michael Schwendt 2005-04-28 00:03:08 UTC
*** Bug 156096 has been marked as a duplicate of this bug. ***

Comment 2 Thomas Vander Stichele 2005-04-28 12:32:06 UTC
Are you saying gstreamer-python is in FC4test2 ?

Comment 3 Jacob Kroon 2005-04-28 13:09:50 UTC
Well, it is in Fedora Extras Development, which I assume will sometime fork off
into Fedora Extras 4. Fedora Extras Development _is_ enabled by default in
FC4test2, so "yum install gstreamer-python" works, and therefore I assumed it is
really a bug for FC4 Extras.

Comment 4 Michael Schwendt 2005-04-28 13:30:22 UTC
*** Bug 156214 has been marked as a duplicate of this bug. ***

Comment 5 Michael Schwendt 2005-04-28 13:30:35 UTC
*** Bug 156215 has been marked as a duplicate of this bug. ***

Comment 6 Michael Schwendt 2005-04-28 13:32:11 UTC
Requesting rebuild of current version in CVS (0.8.1-3) should fix this. Seems,
the previous rebuild for Rawhide has never made it and the binary in the
repository is still the copied FC3 binary.


Comment 7 Thorsten Leemhuis 2005-05-11 10:52:43 UTC
During fixing x86_64 for FC3-extras I also fixed the the devel-version and
requested a rebuild of gstreamer-python; It failed:
http://extras64.linux.duke.edu/failed/development/gstreamer-python/0.8.1-5/i386/gstreamer-python-0.8.1-5.failure.log

Main Error:
xmlto --skip-validation -o /usr/src/rpm/BUILD/gst-python-0.8.1/docs -m
./common.xsl -m ./full.xsl -m ./html.xsl xhtml-nochunks README.xml
ELinks: No such file or directory

Anyone any idea what's wrong there? It builds fine on mx x86_64 FC4T3 (but I
have not yet a mach with FC4T3 to look for missing BuildRequires). If no one has
a idea I'll probably look at it again next week.

Comment 8 Michael Schwendt 2005-05-11 12:09:39 UTC
All the "Could not write method..." and "Could not write function..." messages
during %build (see log) are scary at least, e.g.:

Could not write method GstEvent.discont_get_value: No ArgType for 'gint64*'
Could not write method GstPlugin.get_module: No ArgType for 'GModule*'
Could not write method GstPlugin.feature_filter: No ArgType for
'GstPluginFeatureFilter'

[...]

i386 rebuild on Rawhide ends with:

xmlto --skip-validation -o /home/misc/tmp/rpm/BUILD/gst-python-0.8.1/docs -m
./common.xsl -m ./full.xsl -m ./html.xsl xhtml-nochunks README.xml
No way to convert HTML to text found.

That was with "sudo rpm -e elinks --nodeps", which breaks gstreamer-python's
"BuildRequires: links". The "ELinks: no such file or directory" error smells a
bit like it's from that area, too. Maybe it tries to load style sheets from the
network...


Comment 9 Thorsten Leemhuis 2005-05-11 13:41:27 UTC
(In reply to comment #8)
> Maybe it tries to load style sheets from the
> network...

Well, the FC-3 Version (nearly the same Spec) compiled fine in the build-system... 



Comment 10 Michael Schwendt 2005-05-11 14:01:35 UTC
Well, FC3 != FC4, elinks-0.9.2-2.1 != elinks-0.10.3-1, and "strings
/usr/bin/elinks  | grep ELinks" gives many (!) hits. Suspicious... ;)

Comment 11 Jacob Kroon 2005-05-23 13:30:38 UTC
Using the latest release gstreamer-python-0.8.1-6, everything seems to work fine
again. In general, whose job is it to mark the bug as closed ?


Note You need to log in before you can comment on or make changes to this bug.