Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156090 - OOo cannot save gif animations - file loss
Summary: OOo cannot save gif animations - file loss
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 14:01 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-04 16:41:29 UTC


Attachments (Terms of Use)
simple .sxi with animated gif (deleted)
2005-05-04 16:41 UTC, Caolan McNamara
no flags Details

Description Sammy 2005-04-27 14:01:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.0 (like Gecko)

Description of problem:
If you have a impress file with an embedded gif animation and try to save 
this file it starts the save and at the end it says it cannot write the file and 
leaves a 0 length file behind. 
 
The same thing happens if one tries to export to PDF. 

Version-Release number of selected component (if applicable):
openoffice.org-1.9.96-2

How reproducible:
Always

Steps to Reproduce:
1. install latest oo from rawhide 
2. open a presentation containing a gif animation and make a change 
3. try to save 
   

Additional info:

Comment 1 Caolan McNamara 2005-04-27 14:08:24 UTC
can you attach a sample file which when saved shows this problem

Comment 2 Sammy 2005-04-27 15:35:14 UTC
Well, the problem seems to be more severe and may not have to do with the 
gif animations. Basically, I load a .sxi file which was created by 1.1.3.
I can save it right away (without making any changes) as a .odp file. Then
I make some changes and try to save it, it gives an error message saying
"Write error" and "cannot write file".

In addition, I had random crashes when deleting stuff from an existing
presentation. Happened three times within the last hour but somewhat random.

I am at today's rawhide level as far as all the other packages are concerned.

I have to go back to 1.1.3 since I have a lot to do tiday.

Comment 3 Caolan McNamara 2005-04-29 12:45:07 UTC
It would be great if you could attach a .sxi which reproduces this problem.

Comment 4 Caolan McNamara 2005-05-04 16:41:12 UTC
Created attachment 114026 [details]
simple .sxi with animated gif

If i load this .sxi in 1.9.100-1 and save as .odp and make changes and "save" I
get no errors.


Note You need to log in before you can comment on or make changes to this bug.