Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156085 - ctrl-c exits R session in sesh when run using sudo with selinux enabled
Summary: ctrl-c exits R session in sesh when run using sudo with selinux enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: sudo
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
: 156086 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 13:16 UTC by Marc Schwartz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.6.8p12-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-29 19:41:31 UTC


Attachments (Terms of Use)

Description Marc Schwartz 2005-04-27 13:16:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
When running R (http://www.r-project.org/) version 2.1.0 in a console using 'sudo R', ctrl-c will exit R and return to the console command line, however leaving an R process running. This has been replicated with at least one prior R version as well.

It appears that R is run in sesh in this situation. Presumably, ctrl-c kills sesh, but does not kill R.

A bug was filed in the R bug tracking system:

http://r-bugs.biostat.ku.dk/cgi-bin/R/incoming?id=7819;user=guest;selectid=7819

However this appears to be related to using "sudo R" when SELinux is enabled, as the ctrl-c behavior does not occur when SELinux is disabled.

Relevant output from "ps -aux" shows:

root     12272 49.2  0.8 23108 16924 ?       R    07:45   2:07 /usr/local/lib/R/bin/exec/R
root     15503  0.0  0.0  2556  252 pts/1    S+   07:46   0:00 sesh /usr/local/bin/R
root     15626  0.5  0.8 23204 16920 pts/1   S+   07:46   0:00 /usr/local/lib/R/bin/exec/R

The first R session is what remains from the prior ctrl-c event.

Relevant content from /etc/sudoers is:

marcs   ALL=(ALL) ALL


Version-Release number of selected component (if applicable):
sudo-1.6.7p5-30.1

How reproducible:
Always

Steps to Reproduce:
With SELinux enabled:

1. Run "sudo R" from a terminal emulator
2. Enter password
3. R loads
4. Press ctrl-c once at the R prompt


Actual Results:  It appears that sesh is killed, exiting the R session. However an R process remains.


Expected Results:  Presumably ctrl-c should not kill sesh and the R session


Additional info:

Comment 1 Thomas Woerner 2005-04-27 13:19:57 UTC
*** Bug 156086 has been marked as a duplicate of this bug. ***

Comment 2 Karel Zak 2006-05-29 19:41:31 UTC
The sudo command doesn't use sesh in distributions >=FC5. Closing.


Note You need to log in before you can comment on or make changes to this bug.