Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156068 - win2003 sp1 breaks samba winbind
Summary: win2003 sp1 breaks samba winbind
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba
Version: 3.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
: 157198 (view as bug list)
Depends On:
Blocks: 156321
TreeView+ depends on / blocked
 
Reported: 2005-04-27 10:51 UTC by EE CAP Admin
Modified: 2014-08-31 23:27 UTC (History)
8 users (show)

Fixed In Version: RHBA-2005-634
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 15:58:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:634 qe-ready SHIPPED_LIVE samba bug fix update 2005-09-28 04:00:00 UTC

Description EE CAP Admin 2005-04-27 10:51:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Red Hat/1.0.3-1.4.1 Firefox/1.0.3

Description of problem:
an update to win2003 domain controllers to SP1 has broken winbind on EL3 and I gues EL4 too.  (but until you release a version of EL4 with working nfs ACLs I cannot upgrade to that to test)

                 ===============================
                   Release Notes for Samba 3.0.14a
                              Apr 14, 2005
                   ===============================

Common bugs fixed in 3.0.14a include:

  o Compatibility issues between Winbind and Windows 2003 SP1
    domain controllers (*2k3sp1*).
  o MS-DFS errors with Windows XP SP2 clients.
  o High CPU loads caused by infinite loops in the FindNext()
    server code.
  o Invalid SMB_ASSERT() which caused smbd to panic on ACL'd 
    files.

Version-Release number of selected component (if applicable):
samba-3.0.9-1.3E.2

How reproducible:
Always

Steps to Reproduce:
1. upgrade your ADS server to 2003 sp1
2. ACLs will break on your unix fileserver running EL3
3. 
  

Actual Results:  ACLs no longer appear in the windows security dialogue box... I just get windows SID umbers and I can't remember those off the top of my head.

Expected Results:  I see usernames and not numbers in the windows security dialogue.

Additional info:

The samba team released a patch for this on 14th April.  When do we expect this to be fixed in EL3?  It is stopping many of us from working.

Comment 3 EE CAP Admin 2005-05-05 09:26:15 UTC
Guys - can anyone give me info on when this will be fixed?

I see there has now been some activity but some feedback would be welcome.

Paul

Comment 4 Jay Fenlason 2005-05-05 14:47:34 UTC
For scheduling information like that, you need to talk to your support 
contact.  I only make fixes--I don't control when they get released. . . 

Comment 5 EE CAP Admin 2005-05-07 14:15:48 UTC
Jay - thanks.  I'll follow up on our support contract then.

Paul

Comment 6 Jay Fenlason 2005-05-09 14:48:27 UTC
*** Bug 157198 has been marked as a duplicate of this bug. ***

Comment 8 Vince Worthington 2005-06-15 19:20:00 UTC
Will build a 3.0.9-1.3E-based Samba RPM for RHEL4 and try this patch out and
report back on how it works.  I have a Windows 2003 server here in my test
environ  so should be able to confirm if it works.  Will post an update here to
advise.

--vince

Comment 9 Vince Worthington 2005-06-15 19:27:04 UTC
sorry, meant 3.0.9-1.3E.3-based RPM for RHEL3...

Comment 16 Jay Fenlason 2005-08-10 19:48:38 UTC
*** Bug 165607 has been marked as a duplicate of this bug. ***

Comment 17 Pasi Sjöholm 2005-08-10 21:16:21 UTC
--cut--
Release Notes for Samba 3.0.20rc1

    * Disable schannel on the LSA and SAMR pipes in winbindd client 
      code to deal with Windows 2003 SP1 and Windows 2000 SP4 SR1.
--cut--


Comment 18 Red Hat Bugzilla 2005-09-28 15:58:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-634.html



Note You need to log in before you can comment on or make changes to this bug.