Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156061 - Unsure how to install mcrypt and reconfigure PHP
Summary: Unsure how to install mcrypt and reconfigure PHP
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL: https://www.nicholaswilliams.info/enc...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 08:39 UTC by Nicholas Williams
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-27 09:56:27 UTC


Attachments (Terms of Use)

Description Nicholas Williams 2005-04-27 08:39:24 UTC
Description of problem:
I have installed libmcrypt and mcrypt, but am unsure how to reconfigure Fedora Core-included 
installation of PHP so that it recognizes mcrypt_ecb functions. I hate to put something like this on here 
since it's not really a "bug", but I have googled it and searched this site thoroughly, and nobody seems 
to be able to explain how to do it. Is it a matter of simply making sure the following files get created?
/etc/php.d/mcrypt.ini
/usr/lib/php/mcrypt.so
Or is there something I have to do to change the installation of PHP so that it recognizes mcrypt 
functions? Any help would be GREATLY appreciated, because my server was ready to go two months 
ago, but mcrypt is what has been keeping me from uploading my website. And now, what with 
upgrades galore and reinstallations, I'm too invested in mcrypt to simply say "to heck with it" and use a 
hash.

Version-Release number of selected component (if applicable):
Fedora Core 4 running Apache 2.0.3-x and PHP 5.0.4-x

How reproducible:
Try to install mcrypt. Seriously, mcrypt needs to be added to the package, I think. If it's a licensing 
issue, than make a deal with someone. These functions are too valuable not to include in a project this 
diverse.
  
Actual results:
PHP returns "function mcrypt_ecb not recognized"

Expected results:
I get 256-bit encryption of my users' passwords before they're entered into the database

Additional info:
Nothing I can think of. The attached link is a page I created to test the mcrypt function when I first 
began using it on my Apache/PHP setup on my laptop. Now it's my work-o-meter to tell me when I've 
figured this darn thing out or when it's still not working. :-/

Comment 1 Joe Orton 2005-04-27 09:56:27 UTC
This is not a support forum, please ask fedora-list@redhat.com for help. 
php-mcrypt is not built because mcrypt is not enabled in the distribution; see
bug 114297. 


Note You need to log in before you can comment on or make changes to this bug.