Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156060 - Order of listing errata is inconsistent
Summary: Order of listing errata is inconsistent
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 370
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Michael Bowman
QA Contact: Max Spevack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 08:31 UTC by Nick Strugnell
Modified: 2007-07-31 15:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-30 19:08:03 UTC


Attachments (Terms of Use)

Description Nick Strugnell 2005-04-27 08:31:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040303

Description of problem:
Listing errata under the errata tab, the newest errata are shown first. However listing errata for a particular channel, the oldest errata are shown first.

It would be good to have some consistency - it would be even better if the column headers were clickable to be able to choose the sort order.

Version-Release number of selected component (if applicable):
RHN Satellite 3.7 on RHEL4 AS

How reproducible:
Always

Steps to Reproduce:
1. Navigate to https://<sat server>/network/errata/errata_list/all.pxt and observe that errata are listed most recent first.
2. Navigate to https://<sat server>/network/software/channels/errata.pxt?cid=109 and note that errata are listed most recent last.
3.
  

Actual Results:  Errata ordering is different on different display screens.

Expected Results:  Consistency.

Additional info:

We would also like to be able to choose the search order, for example by clicking on the column headers.

Comment 1 Michael Bowman 2005-06-27 20:08:01 UTC
Works for me... must have been fixed during part of another bug. svn blame says
the Order By part of the query for channels is a recent addition. Verified
hosted and sat environments. Errata queries run by the above pages both have
"ORDER BY  E.update_date DESC" in 'em.

Sortable columns are in the works... Sometime after 410.


Note You need to log in before you can comment on or make changes to this bug.