Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156052 - [ja] missing bterm font warning at boot time
Summary: [ja] missing bterm font warning at boot time
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-27 02:20 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 17:20:14 UTC


Attachments (Terms of Use)

Description Jens Petersen 2005-04-27 02:20:47 UTC
Description of problem:
I'm not sure what the exact cause of this problem with for a while now
with recent trees, a warning is appearing on in the startup messages
on the console about not finding the bterm font.

How reproducible:
every time

Steps to Reproduce:
1. Boot rawhide install (in Japanese system locale?).
2. Look at boot messages on virtual console.
  
Actual results:
2. missing bterm font error message seen.

Expected results:
2. No error.

Comment 1 Jens Petersen 2005-04-27 03:21:59 UTC
The actual line on the console is something like

"Setting default font (bterm): Can't find font bterm."

Comment 2 Jens Petersen 2005-04-27 03:28:57 UTC
Actually "Can't find font file bterm".

This happens with even bogl-bterm installed fwiw.

I noticed that SYSFONT set in /etc/sysconfig/i18n to bterm:
not quite sure why though... so re-assigning to anaconda
for info.

[This is from a rawhide install last week, updated with yum.]

Comment 3 Jeremy Katz 2005-04-27 05:46:05 UTC
Chris, can you take a look at this tomorrow?

Comment 4 Chris Lumens 2005-04-27 14:29:21 UTC
SYSFONT is set to bterm because of the following line in anaconda's lang-table file:

Japanese        ja      bterm   ja_JP.UTF-8     jp106   Asia/Tokyo

Is bterm an incorrect setting?  Should SYSFONT not be getting specified?

Comment 5 Jeremy Katz 2005-04-27 20:00:38 UTC
We need bterm for use in the installer, but it's not valid for the general case.
 I think we used to do some munging to avoid bterm getting written out.

Comment 6 Chris Lumens 2005-04-27 20:50:01 UTC
Fixed in CVS.


Note You need to log in before you can comment on or make changes to this bug.