Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156050 - Kernel panic, uninitialized spinlock in block/cfq-iosched.c:1065
Summary: Kernel panic, uninitialized spinlock in block/cfq-iosched.c:1065
Keywords:
Status: CLOSED DUPLICATE of bug 155472
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-27 01:08 UTC by Eli
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 21:04:24 UTC


Attachments (Terms of Use)

Description Eli 2005-04-27 01:08:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
On shutdown, I once saw a kernel panic, uninitialized spinlock in block/cfq-iosched.c:1065

From my written notes:
Stopping cups: Kernel panic - not syncing: drivers/block/cfq-iosched.c:1065: spin_is_locked on uninitialized spinlock ed89301c. (Not tainted)

I've only seen this once, but due to regressions in other behavior for this kernel, I'm running kernel-2.6.10-1.770_FC3 for the most part.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Didn't try

Steps to Reproduce:
1. Shutdown computer


Actual Results:  Saw kernel panic message as described above.

Expected Results:  Don't panic.

Additional info:

Comment 1 Eli 2005-04-27 02:43:03 UTC
Further testing....  I can get this again on shutdown with kernel-2.6.11-1.14_FC3.
I'm not finding anything in /var/log/* about it, so I'm going by the notes I
jotted down:
I got the same kernel panic message as before, then "atkbd.c: Spurious ACK on
isa0060/serio0.  Some program, like XFree86, might be trying to access hardware
directly." scrolling on the screen.
I had to use the power button to shutdown, and the system complained of an
unclean shutdown when I powered up again.


Comment 2 Dave Jones 2005-04-28 21:04:24 UTC

*** This bug has been marked as a duplicate of 155472 ***


Note You need to log in before you can comment on or make changes to this bug.