Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156047 - khubd timed out on ep0in
Summary: khubd timed out on ep0in
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-26 22:59 UTC by Orion Poplawski
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.6.12-1.1398_FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-22 17:34:27 UTC


Attachments (Terms of Use)
dmesg output (deleted)
2005-06-12 16:47 UTC, Orion Poplawski
no flags Details
dmesg output from development kernel (deleted)
2005-06-13 15:20 UTC, Orion Poplawski
no flags Details
usbmon debug output (deleted)
2005-07-18 20:33 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2005-04-26 22:59:41 UTC
Description of problem:

Trying to attach a USB-2.0 hard drive to a x86_64 FC3 machine.  Get the
following in the logs:

Apr 26 12:33:31 phlebas kernel: usb 1-7: new high speed USB device using
ehci_hcd and address 6
Apr 26 12:33:36 phlebas kernel: usb 1-7: khubd timed out on ep0in
Apr 26 12:33:36 phlebas kernel: usb 1-7: unable to read config index 0
descriptor/all
Apr 26 12:33:36 phlebas kernel: usb 1-7: can't read configurations, error -110
Apr 26 12:33:36 phlebas kernel: usb 1-7: new high speed USB device using
ehci_hcd and address 7
Apr 26 12:33:41 phlebas kernel: usb 1-7: khubd timed out on ep0in
Apr 26 12:33:41 phlebas kernel: usb 1-7: unable to read config index 0
descriptor/start
Apr 26 12:33:41 phlebas kernel: usb 1-7: can't read configurations, error -110
Apr 26 12:33:41 phlebas kernel: usb 1-7: new high speed USB device using
ehci_hcd and address 8
Apr 26 12:33:42 phlebas kernel: usb 1-7: khubd timed out on ep0in
Apr 26 12:33:48 phlebas kernel: usb 1-7: khubd timed out on ep0in
Apr 26 12:33:48 phlebas kernel: usb 1-7: unable to read config index 0
descriptor/all
Apr 26 12:33:48 phlebas kernel: usb 1-7: can't read configurations, error -110
Apr 26 12:33:48 phlebas kernel: usb 1-7: new high speed USB device using
ehci_hcd and address 9
Apr 26 12:33:49 phlebas kernel: usb 1-7: khubd timed out on ep0in
Apr 26 12:33:54 phlebas kernel: usb 1-7: khubd timed out on ep0in
Apr 26 12:33:54 phlebas kernel: usb 1-7: unable to read config index 0
descriptor/all
Apr 26 12:33:54 phlebas kernel: usb 1-7: can't read configurations, error -110


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Everytime

Additional Info:

We can connect and use the device to a FC3 i686 machine with USB1 and a FC1 i686
machine with USB2.

I believe this is the relevant device info gleaned from the FC1 system:

T:  Bus=04 Lev=03 Prnt=03 Port=00 Cnt=01 Dev#=  5 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=05e3 ProdID=0702 Rev= 0.02
S:  Product=USB TO IDE
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 96mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=125us

Comment 1 Pete Zaitcev 2005-06-11 04:46:01 UTC
Please attach full dmesg. If that overflows, /var/log/messages too.
I'm curious if swiotlb is in effect and other details.


Comment 2 Orion Poplawski 2005-06-12 16:47:31 UTC
Created attachment 115339 [details]
dmesg output

dmesg appears complete.

Comment 3 Pete Zaitcev 2005-06-12 17:37:51 UTC
Thanks, dmesg is clean. No swiotlb or anything.

This is a highly unusual failure, but since it's in enumeration, it makes
sense to try a newer kernel, because there were changes in that area.
Can you try an FC4 kernel?
http://download.fedora.redhat.com/pub/fedora/linux/core/development/x86_64/Fedora/RPMS/


Comment 4 Orion Poplawski 2005-06-13 15:20:34 UTC
Created attachment 115353 [details]
dmesg output from development kernel

Well, errors are different with development kernel, but the device still does
not appear to work.  Tested with a different USB disk with the same results so
the problem does not appear to be specific to one device.

Comment 5 Pete Zaitcev 2005-06-13 19:27:48 UTC
Can I bother you with a request for usbmon trace? The usbmon is available on
the new kernel only, but it seems that the failure is similar.

It's done with this:
# mkdir /dbg
# mount -t debugfs none /dbg
# modprobe usbmon
# cat /dbg/usbmon/1t | tee /tmp/mon.1.dump
 <--- insert the device at this point
 <--- wait a few seconds for the timeout
^C


Comment 6 Dave Jones 2005-07-15 20:14:45 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 7 Orion Poplawski 2005-07-18 20:33:37 UTC
Created attachment 116894 [details]
usbmon debug output

Sorry for the delay.  This is with kernel-2.6.12-1.1372_FC3.

syslog output was:

Jul 18 14:29:02 phlebas kernel: usb 1-8: new high speed USB device using
ehci_hcd and address 6
Jul 18 14:29:07 phlebas kernel: Initializing USB Mass Storage driver...
Jul 18 14:29:07 phlebas kernel: scsi2 : SCSI emulation for USB Mass Storage
devices
Jul 18 14:29:07 phlebas kernel: usbcore: registered new driver usb-storage
Jul 18 14:29:07 phlebas kernel: USB Mass Storage support registered.
Jul 18 14:30:28 phlebas kernel: usb 1-8: reset high speed USB device using
ehci_hcd and address 6
Jul 18 14:30:33 phlebas kernel: usb 1-8: device firmware changed
Jul 18 14:30:33 phlebas kernel: scsi: Device offlined - not ready after error
recovery: host 2 channel 0 id 0 lun 0
Jul 18 14:30:33 phlebas kernel: usb 1-8: USB disconnect, address 6
Jul 18 14:30:33 phlebas kernel: Unable to handle kernel NULL pointer
dereference at 0000000000000038 RIP:
Jul 18 14:30:33 phlebas kernel: <ffffffff801eff23>{sysfs_hash_and_remove+19}
Jul 18 14:30:33 phlebas kernel: PGD b318d067 PUD b34bf067 PMD 0
Jul 18 14:30:33 phlebas kernel: Oops: 0000 [1]
Jul 18 14:30:33 phlebas kernel: CPU 0
Jul 18 14:30:33 phlebas kernel: Modules linked in: usb_storage usbmon nfs nfsd
exportfs lockd parport_pc lp parport autofs4 i2c_dev i2c_core sunrpc md5 ipv6
video button battery ac ohci1394 ieee1394 ohci_hcd ehci_hcd snd_intel8x0
snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore
snd_page_alloc forcedeth dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod sata_nv
libata sd_mod scsi_mod
Jul 18 14:30:33 phlebas kernel: Pid: 134, comm: khubd Not tainted
2.6.12-1.1372_FC3
Jul 18 14:30:33 phlebas kernel: RIP: 0010:[<ffffffff801eff23>]
<ffffffff801eff23>{sysfs_hash_and_remove+19}
Jul 18 14:30:33 phlebas kernel: RSP: 0018:ffff810037d33c08  EFLAGS: 00010286
Jul 18 14:30:33 phlebas kernel: RAX: ffffffff88029fa8 RBX: ffffffff88029fa8
RCX: 0000000000000001
Jul 18 14:30:33 phlebas kernel: RDX: ffff8100b4a29b48 RSI: 000000000000006c
RDI: 0000000000000000
Jul 18 14:30:33 phlebas kernel: RBP: 0000000000000000 R08: 0000000000000000
R09: 0000000000000003
Jul 18 14:30:33 phlebas kernel: R10: 00000000ffffffff R11: ffffffff801bfec0
R12: ffffffff88029fa8
Jul 18 14:30:33 phlebas kernel: R13: ffffffff88029ea0 R14: ffffffff803d1a47
R15: ffff8100be6e3800
Jul 18 14:30:33 phlebas kernel: FS:  00002aaaaaabeb00(0000)
GS:ffffffff8055ce00(0000) knlGS:00000000f7fea6c0
Jul 18 14:30:33 phlebas kernel: CS:  0010 DS: 0018 ES: 0018 CR0:
000000008005003b
Jul 18 14:30:33 phlebas kernel: CR2: 0000000000000038 CR3: 00000000bcb3d000
CR4: 00000000000006e0
Jul 18 14:30:33 phlebas kernel: Process khubd (pid: 134, threadinfo
ffff810037d32000, task ffff810037c610f0)
Jul 18 14:30:33 phlebas kernel: Stack: ffffffff88029fa8 ffff8100b4a29b48
ffffffff88029fa8 ffffffff88029ea0
Jul 18 14:30:33 phlebas kernel:        ffff8100b4a29b58 ffffffff802b6deb
ffff8100b4a29b48 ffff8100b7de60b0
Jul 18 14:30:33 phlebas kernel:        ffff8100b4a29a18 ffff8100b7de6000
Jul 18 14:30:33 phlebas kernel: Call
Trace:<ffffffff802b6deb>{class_device_del+187}
<ffffffff802b6e79>{class_device_unregister+9}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff8800d06a>{:scsi_mod:scsi_remove_device+106}
Jul 18 14:30:33 phlebas kernel:        <ffffffff80302af0>{urb_destroy+0}
<ffffffff8800d527>{:scsi_mod:__scsi_remove_target+407}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff8800d6b0>{:scsi_mod:scsi_remove_target+32}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff8800c1dd>{:scsi_mod:scsi_forget_host+317}
<ffffffff880021f6>{:scsi_mod:scsi_remove_host+22}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff8831d44a>{:usb_storage:storage_disconnect+106}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff802fada2>{usb_unbind_interface+82}
<ffffffff802b5a7f>{device_release_driver+111}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff802b5cc8>{bus_remove_device+200} <ffffffff802b4a99>{device_del+105}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff80304af4>{usb_disable_device+148}
<ffffffff802fd91b>{usb_disconnect+235}
Jul 18 14:30:33 phlebas kernel:        <ffffffff802ff167>{hub_thread+1223}
<ffffffff8015a5c0>{autoremove_wake_function+0}
Jul 18 14:30:33 phlebas kernel:        <ffffffff8013d92e>{do_exit+3566}
<ffffffff8015a5c0>{autoremove_wake_function+0}
Jul 18 14:30:33 phlebas kernel:        <ffffffff8010fbcb>{child_rip+8}
<ffffffff802feca0>{hub_thread+0}
Jul 18 14:30:33 phlebas kernel:        <ffffffff8010fbc3>{child_rip+0}
Jul 18 14:30:33 phlebas kernel:
Jul 18 14:30:33 phlebas kernel: Code: 4c 8b 67 38 4c 8b af b0 00 00 00 48 c7 c7
0e 04 3c 80 e8 e6
Jul 18 14:30:33 phlebas kernel: RIP
<ffffffff801eff23>{sysfs_hash_and_remove+19} RSP <ffff810037d33c08>
Jul 18 14:30:33 phlebas kernel: CR2: 0000000000000038
Jul 18 14:30:33 phlebas kernel:  <3>Debug: sleeping function called from
invalid context at include/linux/rwsem.h:43
Jul 18 14:30:33 phlebas kernel: in_atomic():0, irqs_disabled():1
Jul 18 14:30:33 phlebas kernel:
Jul 18 14:30:33 phlebas kernel: Call
Trace:<ffffffff801337df>{__might_sleep+191}
<ffffffff8013acc9>{profile_task_exit+41}
Jul 18 14:30:33 phlebas kernel:        <ffffffff8013cb62>{do_exit+34}
<ffffffff8029829a>{do_unblank_screen+154}
Jul 18 14:30:33 phlebas kernel:        <ffffffff80124b1f>{do_page_fault+1839}
<ffffffff803a6cc0>{thread_return+0}
Jul 18 14:30:33 phlebas kernel:        <ffffffff8010fa15>{error_exit+0}
<ffffffff801bfec0>{generic_delete_inode+0}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff801eff23>{sysfs_hash_and_remove+19}
<ffffffff802b6deb>{class_device_del+187}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff802b6e79>{class_device_unregister+9}
<ffffffff8800d06a>{:scsi_mod:scsi_remove_device+106}
Jul 18 14:30:33 phlebas kernel:        <ffffffff80302af0>{urb_destroy+0}
<ffffffff8800d527>{:scsi_mod:__scsi_remove_target+407}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff8800d6b0>{:scsi_mod:scsi_remove_target+32}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff8800c1dd>{:scsi_mod:scsi_forget_host+317}
<ffffffff880021f6>{:scsi_mod:scsi_remove_host+22}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff8831d44a>{:usb_storage:storage_disconnect+106}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff802fada2>{usb_unbind_interface+82}
<ffffffff802b5a7f>{device_release_driver+111}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff802b5cc8>{bus_remove_device+200} <ffffffff802b4a99>{device_del+105}
Jul 18 14:30:33 phlebas kernel:       
<ffffffff80304af4>{usb_disable_device+148}
<ffffffff802fd91b>{usb_disconnect+235}
Jul 18 14:30:33 phlebas kernel:        <ffffffff802ff167>{hub_thread+1223}
<ffffffff8015a5c0>{autoremove_wake_function+0}
Jul 18 14:30:33 phlebas kernel:        <ffffffff8013d92e>{do_exit+3566}
<ffffffff8015a5c0>{autoremove_wake_function+0}
Jul 18 14:30:33 phlebas kernel:        <ffffffff8010fbcb>{child_rip+8}
<ffffffff802feca0>{hub_thread+0}
Jul 18 14:30:33 phlebas kernel:        <ffffffff8010fbc3>{child_rip+0}

Comment 8 Orion Poplawski 2005-08-22 17:34:27 UTC
This appears to be resolved with an upgrade to FC4 and 2.6.12-1.1398_FC4


Note You need to log in before you can comment on or make changes to this bug.