Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156045 - strace -f file-roller causes immediate segfault in child process
Summary: strace -f file-roller causes immediate segfault in child process
Keywords:
Status: CLOSED DUPLICATE of bug 156908
Alias: None
Product: Fedora
Classification: Fedora
Component: strace
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Roland McGrath
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-26 22:52 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 08:08:23 UTC


Attachments (Terms of Use)
strace output (deleted)
2005-04-26 22:57 UTC, Robin Green
no flags Details

Description Robin Green 2005-04-26 22:52:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
I tried to run file-roller under strace, but a child process died so it couldn't read the specified file. It opens the file fine when strace is not used.

Version-Release number of selected component (if applicable):
strace-4.5.11-1

How reproducible:
Always

Steps to Reproduce:
1. strace -f file-roller foo.zip
  

Actual Results:  file-roller popped up an error dialog box "An error occurred while opening the archive". strace output shows that a child process immediately segfaults after being cloned (see strace output, attached).

Expected Results:  file-roller behaviour should be unchanged

Additional info:

glibc-2.3.5-1
kernel-2.6.11-1.1261_FC4

Comment 1 Robin Green 2005-04-26 22:57:34 UTC
Created attachment 113696 [details]
strace output

Comment 2 Michael Young 2005-05-06 09:27:34 UTC
Actually strace -f anything_that_forks seems to do it, and it appears to be a
kernel bug, see bug 156908 

Comment 3 Roland McGrath 2005-05-09 08:08:23 UTC

*** This bug has been marked as a duplicate of 156908 ***


Note You need to log in before you can comment on or make changes to this bug.