Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156033 - Printing Silently fails shows only in cups error_log
Summary: Printing Silently fails shows only in cups error_log
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL: www.royalpublishing.com/cups.log
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-26 19:38 UTC by Dennis Gilmore
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 08:24:46 UTC


Attachments (Terms of Use)
output from printconf-tui (deleted)
2005-05-04 21:03 UTC, Dennis Gilmore
no flags Details

Description Dennis Gilmore 2005-04-26 19:38:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.0 (like Gecko)

Description of problem:
When trying to print anything KDE printer monitor acts as if the job has    
succesfully printed.  nothing comes out of the printer.  cups error log shows    
a failure and suggets debug logging  with debug logging enabled i get  in the 
url   
   
I am having the same issue on two different FC4T2 boxes  with different   
printers  one is a hp Laserjet 1012  the other is a Samsung ML 1740   
   

Version-Release number of selected component (if applicable):
ghostscript-7.07-40

How reproducible:
Always

Steps to Reproduce:
1. print document  
2. 
3. 
   

Actual Results:  No Output 

Expected Results:  Job to be printed 

Additional info:

Comment 1 Tim Waugh 2005-04-27 12:14:31 UTC
Does the CUPS test page (/usr/share/cups/data/testprint.ps) work?

Comment 2 Dennis Gilmore 2005-04-28 10:52:03 UTC
The test page prints ok 

Comment 3 Tim Waugh 2005-04-28 12:06:41 UTC
What is the least complicated job that fails to print?

Comment 4 Dennis Gilmore 2005-04-28 13:48:53 UTC
i created a one line text document in kate  and it failed to print  

Comment 5 Tim Waugh 2005-05-04 11:56:30 UTC
Please attach the output of 'printconf-tui --Xexport'.  Thanks.

Comment 6 Dennis Gilmore 2005-05-04 21:03:37 UTC
Created attachment 114041 [details]
output from printconf-tui

Comment 7 Dennis Gilmore 2005-05-04 21:06:58 UTC
 i have found that firefox prints ok as does a text document if i run lpr  
<document> at the command line  but printing from any kde application fails on  
my HP Laserjet 1012 at work  Openoffice.org prints ok from here.  i will test  
my Samsung some more at home tonight.  

Comment 8 Tim Waugh 2005-05-05 11:05:42 UTC
I get this from error_log when printing a single line from kate using your
configuration settings:

D [05/May/2005:11:53:58 +0100] [Job 4] renderer PID kid4=4696
D [05/May/2005:11:53:58 +0100] [Job 4] renderer command: gs -q -dBATCH
-dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs
-sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="HP LaserJet"
-dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792 -dDuplex=false -r300
-sIjsParams=Quality:Quality=0,Quality:ColorMode=0,Quality:MediaType=0,Quality:PenSet=0,PS:MediaPosition=7
-dIjsUseOutputFD -sOutputFile=- -
D [05/May/2005:11:53:58 +0100] [Job 4] foomatic-gswrapper: gs '-dBATCH'
'-dPARANOIDSAFER' '-dQUIET' '-dNOPAUSE' '-sDEVICE=ijs' '-sIjsServer=hpijs'
'-sDeviceManufacturer=HEWLETT-PACKARD' '-sDeviceModel=HP LaserJet'
'-dDEVICEWIDTHPOINTS=612'
'-dDEVICEHEIGHTPOINTS=792' '-dDuplex=false' '-r300'
'-sIjsParams=Quality:Quality=0,Quality:ColorMode=0,Quality:MediaType=0,Quality:PenSet=0,PS:MediaPosition=7'
'-dIjsUseOutputFD' '-sOutputFile=| cat >&3' '/dev/fd/0' 3>&1 1>&2
D [05/May/2005:11:53:59 +0100] [Job 4]
D [05/May/2005:11:53:59 +0100] [Job 4] Closing renderer
D [05/May/2005:11:53:59 +0100] [Job 4] Error: /undefined in 35.:
D [05/May/2005:11:53:59 +0100] [Job 4] Operand stack:
D [05/May/2005:11:53:59 +0100] [Job 4]
D [05/May/2005:11:53:59 +0100] [Job 4] Execution stack:
D [05/May/2005:11:53:59 +0100] [Job 4] %interp_exit   .runexec2  
--nostringval--   --nostringval--   --nostringval--   2   %stopped_push  
--nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push
  1   3   %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   1   3  
%oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval-- 
 2   %stopped_push
--nostringval--   --nostringval--   --nostringval--   --nostringval--  
--nostringval--
D [05/May/2005:11:53:59 +0100] [Job 4] Dictionary stack:
D [05/May/2005:11:53:59 +0100] [Job 4] --dict:1078/1123(ro)(G)--  
--dict:1/20(G)--   --dict:178/200(L)--
D [05/May/2005:11:53:59 +0100] [Job 4] Current allocation mode is local
D [05/May/2005:11:53:59 +0100] [Job 4] Last OS error: 2
D [05/May/2005:11:53:59 +0100] [Job 4] GNU Ghostscript 7.07: Unrecoverable
error, exit code 1
D [05/May/2005:11:53:59 +0100] [Job 4] renderer return value: 1
D [05/May/2005:11:53:59 +0100] [Job 4] renderer received signal: 1

Not sure yet whether the fault lies with ghostscript, kate, foomatic, or
something else.

Comment 9 Tim Waugh 2005-05-05 11:29:17 UTC
Okay, the problem seems to be in qt.  It's generating this code, even with
'Print to file':

/pageinit {
35.: 24 translate
% 191*262mm (portrait)
0 744 translate 0.75 -0.75 scale/defM matrix CM d } d

The ".:" here makes no sense, and there's no indication in the source code about
how that might have happened.  Possible compiler/C library bug?

The source code I'm looking at, for reference, is in
qt-x11-free-3.3.4/src/kernel/qpsprinter.cpp:5974-5983:

    outStream << "/pageinit {\n";
    if ( !printer->fullPage() ) {
        if ( printer->orientation() == QPrinter::Portrait )
            outStream << mleft*scale << " "
                   << mbottom*scale << " translate\n";
        else
            outStream << mtop*scale << " "
                   << mleft*scale << " translate\n";
    }


Comment 10 Ngo Than 2005-05-11 12:16:23 UTC
it seems a compiler bug, which has caused this problem.

Could you please try to downgrade to qt-3.3.4-10. Does this problem still appear?

Comment 11 Dennis Gilmore 2005-05-11 13:27:05 UTC
Printing works as expected using  qt-3.3.4-10  

Comment 12 Ngo Than 2005-05-19 08:24:46 UTC
it's now fixed in qt-3.3.4-14. Many thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.