Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156003 - error loading theme Default; can't open Default/Default.xml
Summary: error loading theme Default; can't open Default/Default.xml
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-themes
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
: 156034 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-26 15:50 UTC by John Reiser
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-27 03:41:56 UTC


Attachments (Terms of Use)

Description John Reiser 2005-04-26 15:50:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2) Gecko/20040308

Description of problem:
Reboot to mulituser (after this morning's up2date) cannot login to X11 console. The graphical error box says "There was an error loading the theme Default.  Can't open file /usr/share/gdm/themes/Default/Default.xml".

Indeed, the only files in /usr/share/gdm/themes are: Bluecurve  circles  happygnome  happygnome-list.  Creating directory Default as symlink to Bluecurve, and file Default/Default.xml as symlink to Bluecurve.xml still does not work.
The Welcome box shows Username: with pre-entered "...", but it will not accept a click to focus, no username can be entered, and typing is ignored.  Mouse is active: choosing Session brings up dialog, choices can be selected and OKd, but they have no effect: cannot login.  Console switching via Ctrl-Alt-Fn does not work.


Version-Release number of selected component (if applicable):
gnome-themes-2.10.1-1

How reproducible:
Always

Steps to Reproduce:
1. up2date; reboot; attempt to login to graphical console
2.
3.
  

Actual Results:  Error box with complaint about loading theme Default, and file /usr/share/gdm/themes/Default/Default.xml missing.  No response to typing on console.

Expected Results:  Normal login capability on graphical console.


Additional info:

Comment 1 W J Dearborn 2005-04-26 17:48:02 UTC
Same problem but creating actual /Defaults directory and copying contents of
bluecurve to the /Default directory then copying bluecurve.xml to Defaults.xml
did work

Comment 2 Matthias Clasen 2005-04-27 02:56:41 UTC
*** Bug 156034 has been marked as a duplicate of this bug. ***

Comment 3 Tom Diehl 2005-04-27 13:01:36 UTC
I am courious as to how this was resolved? I know I can create the directory/mod
the config file, but why did it happen in the first place and more inportantly
what is being done to fix whatever caused it in the first place? IOW why was it
closed? Did I miss something?

Comment 4 Matthias Clasen 2005-04-27 13:38:39 UTC
We removed the "Default" symlink from the redhat-artwork package, since it shows
up as a duplicate Bluecurve entry in the gdm config tool. This broke gdm, since
we overlooked that the gdm.conf file still referred to the Default theme. The
fix was to make the gdm.conf file refer to Bluecurve directly


Note You need to log in before you can comment on or make changes to this bug.