Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155990 - apt-shell crashes while executing "install kernel"
Summary: apt-shell crashes while executing "install kernel"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apt
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-26 14:19 UTC by Stefan Hoelldampf
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.5.15cnc7-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 18:29:28 UTC


Attachments (Terms of Use)
Fix the segfault (deleted)
2005-04-28 15:51 UTC, Panu Matilainen
no flags Details | Diff

Description Stefan Hoelldampf 2005-04-26 14:19:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
apt-shell crashes while executing "install kernel".


Version-Release number of selected component (if applicable):
apt-0.5.15cnc7-1

How reproducible:
Always

Steps to Reproduce:
1. Start apt-shell as root
2. Type "install kernel"


Actual Results:  > # apt-shell
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Welcome to the APT shell. Type "help" for more information.
> apt> install kernel
> Package kernel is a virtual package provided by:
> Segmentation fault
> # 


Expected Results:  No segmentation fault


Additional info:

"apt-get install kernel" does not crash:

> # apt-get install kernel
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Selecting kernel#2.6.11-1.14_FC3 for 'kernel'
> kernel#2.6.11-1.14_FC3 is already the newest version.
> 0 upgraded, 0 newly installed, 0 removed and 0 not upgraded.



I have tried to debug apt using the debuginfo-package and DDD.
apt-shell crashes when calling
   bool Res = Map[I].Handler(*this);
in contrib/cmndline.cc:340 in function
   bool CommandLine::DispatchArg(Dispatch *Map,bool NoMatch)

Unfortunately, GDB crashes itself if I try to step into the funtions :-(

Comment 1 Panu Matilainen 2005-04-28 15:51:22 UTC
Created attachment 113791 [details]
Fix the segfault 

This patch fixes the segfault which was simply caused by just apt-shell having
older buggy copy-pasted code of apt-get.

Comment 2 Panu Matilainen 2005-04-28 15:55:22 UTC
Ville - please add the patch to FE CVS. Dunno if this alone is worth an actual
update, maybe it is because segfaults from package managers aren't nice :-/
Oh and the patch is already in apt-rpm upstream as well.

Comment 3 Ville Skyttä 2005-04-28 20:58:52 UTC
Done for both FC-3 and devel.  You decide whether an update is needed, just go
and add apt to the FC3Status and FC4Status queues if so.

Comment 4 Panu Matilainen 2005-06-27 18:29:28 UTC
This is fixed in the version that landed in extras last week.


Note You need to log in before you can comment on or make changes to this bug.