Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155983 - early login fails to login
Summary: early login fails to login
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-26 13:35 UTC by Thomas J. Baker
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-06 18:28:29 UTC


Attachments (Terms of Use)

Description Thomas J. Baker 2005-04-26 13:35:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
I'd been using early-login for a few days but the 4/24 or 4/25 update broke it. Everything looks like it's working normally but when you actually try to login, it complains about "Cannot start the session due to some internal error." The details are that "session_child_run: Could not exec /etc/X11/xdm/Xsession gnome-session". If I restart the system and remove early-login from the kernel cmdline, logging in works fine.

Version-Release number of selected component (if applicable):
gdm-2.6.0.8-7

How reproducible:
Always

Steps to Reproduce:
1. enable early-login
2.
3.
  

Actual Results:  login fails

Expected Results:  login works

Additional info:

I've enabled early-login based on Ray Strode's post a few weeks back. chkconfiged the three gdm related init scripts, changed xfs and syslog start numbers, etc.

Comment 1 Tom London 2005-04-26 13:44:32 UTC
I've seen this problem too.

For me, it seems to be a 'mismatch' caused by early-login and init: some init
scripts appear to be executing in the SELinux domain 'init_t' instead of
'initrc_t'. This appears to cause lots of access failures, I believe when it
checks to see if the display manager is already running. I haven't had time yet
to completely track this down.

The first time this happened, I worked around it by 'CTL-ALT-F2' to a text
screen, logging in as root, and doing a 'setenforce 0'. 'CTL-ALT-F7' restores
the graphical stuff, and things work.

You can also boot with 'early-login enforcing=0'.

Comment 2 Rahul Sundaram 2005-09-05 03:04:11 UTC

Does installing firstboot change anything?. Based on 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=159140

Comment 3 Ray Strode [halfline] 2007-03-06 18:28:29 UTC
I'm going to close this bug, since the early-login experiment is pretty much
over with now.


Note You need to log in before you can comment on or make changes to this bug.