Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155975 - net-snmp update broke php-snmp
Summary: net-snmp update broke php-snmp
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
: 156144 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-26 12:27 UTC by Joe Orton
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: 4.3.11-2.5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-03 15:35:56 UTC


Attachments (Terms of Use)

Description Joe Orton 2005-04-26 12:27:05 UTC
Description of problem:
php-snmp no longer loads after the recent net-snmp update.

Version-Release number of selected component (if applicable):
net-snmp-5.2.1-10.FC3
php-4.3.11-2.4

How reproducible:
always

Steps to Reproduce:
[root@pepsi ~]# php
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/snmp.so'
- /usr/lib/php4/snmp.so: undefined symbol: usmAES192PrivProtocol in Unknown on
line 0

Comment 1 Radek Vokal 2005-04-27 07:39:06 UTC
Strange 'cos I didn't manage to reproduce it here. On updated FC3 with latest
net-snmp-5.2.1-10.FC3 (php.ini set to display all errors) php doesn't show any
warnings or errors (php-4.3.11-2.4). I've tried to recompile php and I'm willing
to do this also for FC3 - this might just be fine for fixing the issue. 

Comment 2 Joe Orton 2005-04-27 07:56:05 UTC
Do you have php-snmp installed?

Comment 3 Radek Vokal 2005-04-27 08:03:11 UTC
$ rpm -q php-snmp
php-snmp-4.3.11-2.4

also my test.php file including <? PHPInfo() ?> works just fine, showing that
snmp module is present. 

Comment 8 Joe Orton 2005-04-27 21:19:30 UTC
*** Bug 156144 has been marked as a duplicate of this bug. ***

Comment 9 Joe Orton 2005-04-27 21:21:21 UTC
A PHP update is in the works to resolve this.

Comment 10 Chris Jones 2005-04-28 17:23:29 UTC
Will this also fix the bug in the php-rrdtool package from fedora extras that
causes the error...
"PHP Warning:  Unknown(): Invalid library (maybe not a PHP library) 'rrdtool.so'
 in Unknown on line 0"

I would file this as a seperate bug under fedora extras but its not entirely
clear what component to file it under

Comment 11 Joe Orton 2005-05-03 15:34:48 UTC
This issue is now fixed in the php-4.3.11-2.5 update:

http://www.redhat.com/archives/fedora-announce-list/2005-May/msg00006.html

RollerCow: file that against php-rrdtool, it looks like a packaging bug.



Comment 12 Rob Kudyba 2005-05-05 01:02:31 UTC
How do we get an update for RH 8 as we're also experiencing this issue?


Note You need to log in before you can comment on or make changes to this bug.