Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155961 - kernel-2.6.11-1.14_FC3 hangs while logging out from GNOME session, after using an USB device.
Summary: kernel-2.6.11-1.14_FC3 hangs while logging out from GNOME session, after usin...
Keywords:
Status: CLOSED DUPLICATE of bug 155472
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-26 07:24 UTC by Hamar Gábor
Modified: 2015-01-04 22:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 21:29:16 UTC


Attachments (Terms of Use)

Description Hamar Gábor 2005-04-26 07:24:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
After using an USB device (i tried an usb pen drive, and a digital camera), kernel-2.6.11-1.14_FC3 hangs while logging out from GNOME session. 

If I don't unplug it, only unmount, I can log out normally.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. Plug an USB device.
2. Unmount and unplug it.
3. Log out from GNOME session.
4. The system hangs
  

Actual Results:  System hangs.

Expected Results:  System log out normally.

Additional info:

I am using a COMPAL CL56 notebook.

Comment 1 Boris Glawe 2005-04-26 20:42:53 UTC
I can confirm this.

The same happens with the machines of my colleagues.

Comment 2 Boris Glawe 2005-04-26 20:53:06 UTC
seems to be fixed in a new kernel: See here:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=155472

Comment 3 Rolf Fokkens 2005-04-26 21:20:44 UTC
Since upgrading to 2.6.11-1.14_FC3 the machine seems to lockup after playing
wolfenstein (DRI). I've seen this twice now. Not immediately after playing the
game, first there's a lot of paging when windows reappear on the desktop. Then
after all seems to be there, at some point the machine may hang, for example on
closing a window.

Not sure if it's related to the USB problem, though I should mention a USB card
reader is connected, and a digital camera may have been connected.

I'll give kernel-2.6.11-1.19_FC3.i686.rpm a try, and see if the problem doesn't
show up again.

Comment 4 Rolf Fokkens 2005-05-07 15:20:16 UTC
It seems that 2.6.11-1.19 is more stable, however when connecting two different
card readers at the same time, lsusb got confused and so did the kernel:

May  7 16:58:22 home01 kernel: Unable to handle kernel paging request at virtual
address 02c00153
May  7 16:58:22 home01 kernel:  printing eip:
May  7 16:58:22 home01 kernel: dfc87561
May  7 16:58:22 home01 kernel: *pde = 00000000
May  7 16:58:22 home01 kernel: Oops: 0000 [#1]
May  7 16:58:22 home01 kernel: Modules linked in: loop nls_utf8 vfat fat
snd_pcm_oss snd_mixer_oss usb_storage i915 drm tun parport_pc lp
parport autofs4 eeprom lm85 i2c_sensor i2c_isa sunrpc md5 ipv6 ipt_MASQUERADE
iptable_nat ipt_LOG ipt_multiport ipt_state ip_conntrack ipt
able_filter ip_tables microcode dm_mod video button battery ac uhci_hcd ehci_hcd
hw_random i2c_i801 i2c_core snd_intel8x0 snd_ac97_codec s
nd_pcm snd_timer snd soundcore snd_page_alloc hisax crc_ccitt isdn slhc tulip
e100 mii floppy ext3 jbd ata_piix libata sd_mod scsi_mod
May  7 16:58:22 home01 kernel: CPU:    0
May  7 16:58:22 home01 kernel: EIP:    0060:[<dfc87561>]    Not tainted VLI
May  7 16:58:22 home01 kernel: EFLAGS: 00010246   (2.6.11-1.19_FC3)
May  7 16:58:22 home01 kernel: EIP is at bus_reset+0xdc/0x214 [usb_storage]
May  7 16:58:22 home01 kernel: eax: 00000015   ebx: dd1ea400   ecx: 02c00007  
edx: 0000006b
May  7 16:58:22 home01 kernel: esi: ded8e800   edi: fffffff0   ebp: 00000000  
esp: ca606e9c
May  7 16:58:22 home01 kernel: ds: 007b   es: 007b   ss: 0068
May  7 16:58:22 home01 kernel: Process scsi_eh_2 (pid: 5052, threadinfo=ca606000
task=c8404db0)
May  7 16:58:22 home01 kernel: Stack: c16b8610 c16b8610 c16b8610 c028949a
00000000 d896ae6c ca606ecc c03a9c20
May  7 16:58:22 home01 kernel:        ded8e800 00000282 00000000 00000000
df85147f c035873e c78d6df0 c78d6df0
May  7 16:58:22 home01 kernel:        c78d6df0 ded8e800 ca606f74 00000206
ded8e200 ca606f74 ded8e818 00000000
May  7 16:58:22 home01 kernel: Call Trace:
May  7 16:58:22 home01 kernel:  [<c028949a>] cfq_next_request+0xef/0x122
May  7 16:58:22 home01 kernel:  [<df85147f>] scsi_try_bus_reset+0xa3/0x380
[scsi_mod]
May  7 16:58:22 home01 kernel:  [<c035873e>] schedule+0x2ce/0x5f5
May  7 16:58:22 home01 kernel:  [<df851b62>] scsi_eh_bus_reset+0x86/0x172 [scsi_mod]
May  7 16:58:22 home01 kernel:  [<df8512e2>] scsi_eh_bus_device_reset+0x16/0x110
[scsi_mod]
May  7 16:58:22 home01 kernel:  [<df85208a>] scsi_eh_ready_devs+0x30/0x4d [scsi_mod]
May  7 16:58:22 home01 kernel:  [<df8522e9>] scsi_unjam_host+0x14e/0x2d8 [scsi_mod]
May  7 16:58:22 home01 kernel:  [<df84d85f>] __scsi_iterate_devices+0xa0/0x17d
[scsi_mod]
May  7 16:58:22 home01 kernel:  [<c011aac8>] default_wake_function+0x0/0xc
May  7 16:58:22 home01 kernel:  [<df8525c1>] scsi_error_handler+0x14e/0x205
[scsi_mod]
May  7 16:58:22 home01 kernel:  [<df852473>] scsi_error_handler+0x0/0x205 [scsi_mod]
May  7 16:58:22 home01 kernel:  [<c0101291>] kernel_thread_helper+0x5/0xb
May  7 16:58:22 home01 kernel: Code: df 8b 46 04 8b 00 8b 40 4c c7 40 14 30 01
00 00 83 c4 20 89 f8 5b c1 f8 1f 5e f7 d0 5f 05 03 20 00 00
 5d c3 8b 4b 28 66 bf f0 ff <8b> 81 4c 01 00 00 80 78 04 01 75 80 8b 53 2c 89 c8
e8 a5 16 63

Comment 5 Dave Jones 2005-05-10 21:28:22 UTC
thats a different bug. Can you file another one please ?

Comment 6 Dave Jones 2005-05-10 21:29:16 UTC

*** This bug has been marked as a duplicate of 155472 ***


Note You need to log in before you can comment on or make changes to this bug.