Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155949 - oprofile fails to build on ia64
Summary: oprofile fails to build on ia64
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: binutils
Version: 4.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Denys Vlasenko
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 23:37 UTC by Martin K. Petersen
Modified: 2009-01-02 12:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-02 12:23:07 UTC


Attachments (Terms of Use)
opd_kernel.i (deleted)
2005-04-26 15:51 UTC, Martin K. Petersen
no flags Details
opd_kernel.s (deleted)
2005-04-26 15:51 UTC, Martin K. Petersen
no flags Details

Description Martin K. Petersen 2005-04-25 23:37:32 UTC
Description of problem:

While compiling upstream oprofile I ran into the following error.
I tried rebuilding oprofile-0.8.1-11.src.rpm provided by RH and got the same result.

Steps to Reproduce:
1. Pristine RHEL4 ia64 machine.
2. rpmbuild --rebuild oprofile-0.8.1-11.src.rpm

Actual results:
[...]
make[3]: Entering directory `/home/buildsys/BUILD/oprofile-0.8.1/daemon/liblegacy'
if gcc4 -DHAVE_CONFIG_H -I. -I../../././daemon/liblegacy -I../..  -I
../../././libutil -I ../../././libop -I ../../././libdb -I ../../././daemon  -W
-Wall -fno-common -Wdeclaration-after-statement -fno-omit-frame-pointer -g -O2
-MT opd_24_stats.o -MD -MP -MF ".deps/opd_24_stats.Tpo" -c -o opd_24_stats.o
opd_24_stats.c; \
then mv -f ".deps/opd_24_stats.Tpo" ".deps/opd_24_stats.Po"; else rm -f
".deps/opd_24_stats.Tpo"; exit 1; fi
if gcc4 -DHAVE_CONFIG_H -I. -I../../././daemon/liblegacy -I../..  -I
../../././libutil -I ../../././libop -I ../../././libdb -I ../../././daemon  -W
-Wall -fno-common -Wdeclaration-after-statement -fno-omit-frame-pointer -g -O2
-MT opd_kernel.o -MD -MP -MF ".deps/opd_kernel.Tpo" -c -o opd_kernel.o
opd_kernel.c; \
then mv -f ".deps/opd_kernel.Tpo" ".deps/opd_kernel.Po"; else rm -f
".deps/opd_kernel.Tpo"; exit 1; fi
/tmp/cc064O9o.s: Assembler messages:
/tmp/cc064O9o.s:2171: Error: Epilogue count of 4294967296 exceeds number of
nested prologues (0)
/tmp/cc064O9o.s:2701: Error: Epilogue count of 4294967296 exceeds number of
nested prologues (0)
make[3]: *** [opd_kernel.o] Error 1

The same code compiles fine with Debian sarge's toolchain.

Comment 1 Jakub Jelinek 2005-04-26 10:53:43 UTC
Please provide preprocessed opd_kernel.i (add -save-temps to your
command gcc command line).  Only with preprocessed source we can be sure we
are looking at the same thing.
Can you reproduce it also with gcc instead of gcc4?

Comment 2 Martin K. Petersen 2005-04-26 15:51:05 UTC
Created attachment 113672 [details]
opd_kernel.i

Comment 3 Martin K. Petersen 2005-04-26 15:51:29 UTC
Created attachment 113673 [details]
opd_kernel.s

Comment 4 Martin K. Petersen 2005-04-26 15:52:30 UTC
Yes.  I've tried both gcc and gcc4. Same thing.

Comment 5 Denys Vlasenko 2008-12-18 18:45:45 UTC
Seems to work on this hardware / release combination:


[root@hp-sapphire-01 tmp]# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 7)

[root@hp-sapphire-01 tmp]# uname -a
Linux hp-sapphire-01.rhts.bos.redhat.com 2.6.9-78.19.EL #1 SMP Fri Nov 21 16:30:22 EST 2008 ia64 ia64 ia64 GNU/Linux

[root@hp-sapphire-01 tmp]# rpm -q binutils
binutils-2.15.92.0.2-25

[root@hp-sapphire-01 tmp]# rpm -q gcc4
gcc4-4.1.2-42.EL4

[root@hp-sapphire-01 tmp]# cat opd.sh
gcc4 -DHAVE_CONFIG_H -W -Wall \
-fno-common -Wdeclaration-after-statement -fno-omit-frame-pointer -g -O2 \
-MT opd_kernel.o -MD -MP -MF "opd_kernel.Tpo" -c -o opd_kernel.o \
opd_kernel.c

[root@hp-sapphire-01 tmp]# sh opd.sh

[root@hp-sapphire-01 tmp]# ls -l
-rw-r--r--  1 root root 107947 Dec 18 13:38 opd_kernel.c
-rw-r--r--  1 root root  32896 Dec 18 13:43 opd_kernel.o


(opd_kernel.c is a file from comment #2)

Comment 6 Denys Vlasenko 2009-01-02 12:22:50 UTC
I'm closing it as "works for me". It indeed works for me, and last comment was from three years ago.

Reopen if this is still a problem.


Note You need to log in before you can comment on or make changes to this bug.