Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155942 - Wildcards in pde config triplets not working
Summary: Wildcards in pde config triplets not working
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 21:50 UTC by Phil Muldoon
Modified: 2018-04-11 15:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 18:21:00 UTC


Attachments (Terms of Use)

Description Phil Muldoon 2005-04-25 21:50:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
PDE based Releng plug-ins provide for build triplets (ie linux,gtk,x86) in the build.properties. This allows for specific targeting of releng based pde builds.  However, the triplets also allow for wildcards (ie linux,gtk,* or even *,*,*). 

In this release, the wildcards are not correctly parsed, and the results of the build in the results/I.{...} folder are empty. Specifically targetting a triplet (ie removing *,*,* in the build.properties file, and adding a specific triplet like linux,x86,gtk) and the build once again works. Note you have to add a corresponding assemble target in the customTargets.xml file. 

This pr was discovered in the eclipse-bugzilla build failing when it had a *,*,* triplet. Adding a specific triplet (linux,gtk,x86) and and corresponding assemble script, and the build once again works. This is different from previous versions of Eclipse.

Version-Release number of selected component (if applicable):
3.1.0_fc-0.M6.9

How reproducible:
Always

Steps to Reproduce:
1. Attempt to build a pde based releng plugin with a wildcard in the configs section of build.properties
2.
3.
  

Actual Results:  The build will fail

Expected Results:  The build should have worked, and the resultant zip/tar placed in results/I{...}

Additional info:

Comment 1 Phil Muldoon 2005-04-26 18:21:00 UTC
On further investigation this is not a bug. It is a change in the pde build
scripts. Previously the pde build mechanism only output builds as zips. With 3.1
the pde build will output builds in a format best suited for that platform (ie
linux = tar). On most occasions, the PDE can guess the format from the
platform/architecture triplet specified. However on vague triplets (like *,*,*)
you have to specify the output format with the:

archiveFormat argument

For example: *,*,*-zip

Adding this argument removes ambiguity and allows the pde to deliver a build.
Without it, it seems, the PDE will not deliver a build in the I{...} results folder.



Note You need to log in before you can comment on or make changes to this bug.