Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155927 - cupsd crashes system hard without any messages on kernels newer than 2.6.9...
Summary: cupsd crashes system hard without any messages on kernels newer than 2.6.9...
Keywords:
Status: CLOSED DUPLICATE of bug 144726
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 20:03 UTC by Remco Treffkorn
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 09:59:24 UTC


Attachments (Terms of Use)

Description Remco Treffkorn 2005-04-25 20:03:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.0 (like Gecko)

Description of problem:
The system crashes hard on cupsd start. No messages are printed to any logs. 
The network stack is dead too, no pings. 
There is absolutely no indication that something is going wrong, except the 
system is dead. No error messages, no logs. Straceing cupsd -f did not tell me 
anything either. No obvious indication of anything going wrong. 
This is on an old Compaq Presario laptop. The same software works fine on 
another intel box. If booting with 2.6.9 everything works without a problem. 
 
The problem here is not the crash, but the fact that there is not any hint of 
a problem. Running strace on cupsd did not tell me a lot. Cupsd seems to exec 
other stuff, though. The problem could be with a child. 
 
Any idea about how to instrument this, so I can find out what causes this?  
 

Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.8.5 kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot with cups service on, system stops on cupsd start 
2. Boot without cups service. Start cupsd manually, system dies. 
3. 
   

Actual Results:  The system is dead. Absolutely no log, or other output before the crash. 
System does not even respond to pings any more. 

Additional info:

I don't see the problem on any machine, but this particular Compaq laptop. 
But on this one it is 100% reproducible. Frustrating really.

Comment 1 Tim Waugh 2005-04-26 09:59:24 UTC

*** This bug has been marked as a duplicate of 144726 ***


Note You need to log in before you can comment on or make changes to this bug.