Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155919 - emacs background-color is not set correctly
Summary: emacs background-color is not set correctly
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 19:21 UTC by greg lonnon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-18 02:49:25 UTC


Attachments (Terms of Use)
.emacs file (deleted)
2005-04-25 19:21 UTC, greg lonnon
no flags Details

Description greg lonnon 2005-04-25 19:21:13 UTC
Description of problem:

When displaying emacs from redhat 9 to a FedoraCore 3 machine, the background
color is not displayed correctly.  The background color changes from gray to
white.  If the .emacs file is run on a rh9 or a fc3 machine it works correctly.
  This only occurs if emacs is running on a redhat9 machine and the display is
sent to a fedora core 3 machine using ssh.

Version-Release number of selected component (if applicable):

rh9 : emacs 21.2.1

How reproducible:

Use this .emacs file.

(add-to-list 'default-frame-alist '(background-color . "gray"))

Steps to Reproduce:
1. Login to a FC3 machine (X11 running on the machine)
2. ssh to a rh9 machine, X11 port forwarding enabled. (-X)
3. emacs .emacs
  
Actual results:

The emacs background should be gray.  In fact, all frames should be gray.  But,
the background is white.  If the same .emacs is run locally  rh9/fc3 X11
display, it works correctly, all frames are background gray. 

Expected results:

The frames are gray.  

Additional info:

Comment 1 greg lonnon 2005-04-25 19:21:13 UTC
Created attachment 113647 [details]
.emacs file

Comment 2 Jens Petersen 2005-04-26 02:45:08 UTC
And this is not a RHL9 emacs bug?  It works ok from FC2 say, you mean? :)

Comment 3 Jens Petersen 2005-05-18 02:49:25 UTC
What happens if you ssh to the local fc3 box?

I just tested this, and I can't reproduce the problem here.



Note You need to log in before you can comment on or make changes to this bug.