Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155916 - PHP Bug 32553 : PHP_STREAM_COPY_ALL set to 2000000
Summary: PHP Bug 32553 : PHP_STREAM_COPY_ALL set to 2000000
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 18:09 UTC by Remi COLLET
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 5.0.4-9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 13:39:17 UTC


Attachments (Terms of Use)
Patch proposal. (deleted)
2005-04-25 18:09 UTC, Remi COLLET
no flags Details | Diff

Description Remi COLLET 2005-04-25 18:09:12 UTC
Description of problem:
See http://bugs.php.net/bug.php?id=32553

This bug is really a problem as PHP cannot read file larger than 2000000 bytes.

Version-Release number of selected component (if applicable):
php-5.0.4-6 from rawhide (since php-5.0.3)

How reproducible:
Always

Steps to Reproduce:
1. using fpasthru on a file larger than 2000000 bytes
2.
3.
  
Actual results:
A file of 2000000 bytes extacly

Expected results:
The same file as the source one.

Additional info:
We can wait for php-5.0.5 (as this bug has been fixed in CVS) or use a very
small/simple patch (see attachment)

Comment 1 Remi COLLET 2005-04-25 18:09:12 UTC
Created attachment 113644 [details]
Patch proposal.

Comment 2 Joe Orton 2005-05-06 10:18:19 UTC
Keeping the old #define commented out with // is not necessary; I just changed
it in-place.  Can you test 5.0.4-9 in Raw Hide?

Comment 3 Remi COLLET 2005-05-06 17:04:09 UTC
This "very" simple tests are ok...

php -r 'fpassthru(fopen("/usr/bin/mplayer","rb"));'"));'>/tmp/mp1
php -r 'readfile("/usr/bin/mplayer");'>/tmp/mp2

File /usr/bin/mplayer, /tmp/mp1 and /tmp/mp2 are the identical.

Thanks


Note You need to log in before you can comment on or make changes to this bug.