Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155908 - rpm update loses local changes
Summary: rpm update loses local changes
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: logwatch
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jiri Ryska
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 17:03 UTC by Brittany Software
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 13:58:09 UTC


Attachments (Terms of Use)

Description Brittany Software 2005-04-25 17:03:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
when updating, local changes in /etc/log.d/scripts/services/* are lost and no .rpmnew or .orig files are created

Version-Release number of selected component (if applicable):
logwatch-5.2.2-1.FC3.1

How reproducible:
Always

Steps to Reproduce:
1. make local changes in /etc/log.d/scripts/services/postfix for instance
2. update to logwatch-5.2.2-1.FC3.1

  

Actual Results:  local changes are lost

Expected Results:  .rpmnew or .orig file should have been created

Additional info:

Comment 1 Jiri Ryska 2005-04-26 13:58:09 UTC
This is not a bug because these files (in /etc/log.d/scripts/services/) are in
fact executables. This is the same as if you compile your own binary, for
example /bin/bash. So when you upgrade bash, this file /bin/bash will be
replaced. Files that have backups are config files. 


Note You need to log in before you can comment on or make changes to this bug.