Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155901 - Enscript doesn't support UTF-8.
Summary: Enscript doesn't support UTF-8.
Keywords:
Status: CLOSED DUPLICATE of bug 81828
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: enscript
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact: Jay Turner
URL:
Whiteboard:
: 155898 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 15:22 UTC by Björn Augustsson
Modified: 2015-01-08 00:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 15:54:20 UTC


Attachments (Terms of Use)

Description Björn Augustsson 2005-04-25 15:22:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.4) Gecko/20050318 Red Hat/1.4.4-1.3.5

Description of problem:
Enscript cannot print UTF-8 (or any other unicode encoding) files.

This also applies to previous versions of RHEL, as well as the current
beta of RHEL 4 update 1.

Seeing as UTF-8 is the default encoding in RHEL 3 and 4, that should probably
get fixed.

This is actually kind of a regression against RHEL 2.1, since that didn't 
have UTF-8 as the default, and hence you could print files made in the normal
way back then, and now you can't. 

/August.

Version-Release number of selected component (if applicable):
enscript-1.6.1-28.3

How reproducible:
Always

Steps to Reproduce:
1. Open "vi"
2. Make a text file, containing a non-7-bit-ascii character of your choice.
   (My example: [Hmm, cannot enter it here, or I get an 5XX internal error
   from bugzilla...] anyway, an "a" with a ring above it)
3. enscript <file>
  

Actual Results:  A sheet of paper (if you had printing set up right) containing something like
(for the a-with-ring example above) <A with a tilde above it>\203<A with a circumflexover it><yen sign>.


Expected Results:  A sheet of paper with a proper (albeit non-7-bit) character on it.


Additional info:

Comment 1 Tim Waugh 2005-04-25 15:53:07 UTC
*** Bug 155898 has been marked as a duplicate of this bug. ***

Comment 2 Tim Waugh 2005-04-25 15:54:20 UTC
I think it should work to print the text file using 'lpr', thought.

But yes, enscript ought to support UTF-8.

*** This bug has been marked as a duplicate of 81828 ***


Note You need to log in before you can comment on or make changes to this bug.