Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155880 - Need to edit /usr/share/texmf/pxdvi/vfontmap because of font dir change
Summary: Need to edit /usr/share/texmf/pxdvi/vfontmap because of font dir change
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 09:43 UTC by Mamoru TASAKA
Modified: 2013-07-02 23:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-01 13:24:40 UTC


Attachments (Terms of Use)
sample dvi file which needs Japanese font (deleted)
2005-04-25 13:15 UTC, Mamoru TASAKA
no flags Details
The source TeX document (deleted)
2005-04-25 13:24 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2005-04-25 09:43:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
After I upgrade fonts-ja to fonts-japanese,  seeing Japanese dvi file
with pxdvi immediately exits with the exit number 101 and the message 
"FT2: Open Font Error. (/usr/share/fonts/ja/TrueType/kochi-mincho-subst.ttf)"

This is because Japanese fonts were moved from /usr/share/fonts/ja/...
to /usr/share/fonts/japanese/... but the description in the file 
/usr/share/texmf/pxdvi/vfontmap doesn't match this. 

[user@halo TEMP]$ rpm -q --changelog fonts-japanese
* Fri Feb 25 2005 Akira TAGOH <tagoh@redhat.com> - 0.20050222-2

- Use /usr/share/fonts/japanese instead of /usr/share/fonts/ja

Please edit /usr/share/texmf/pxdvi/vfontmap .



Version-Release number of selected component (if applicable):
tetex-xdvi-3.0-3  fonts-japanese-3.0-3

How reproducible:
Always

Steps to Reproduce:
1. Make dvi file which needs Japanese font to see.
2. See the dvi file with pxdvi
3.
  

Actual Results:  pxdvi exits immediately with error

Expected Results:  pxdvi can be truly executed

Additional info:

Comment 1 Mamoru TASAKA 2005-04-25 10:02:31 UTC
> Version-Release number of selected component (if applicable):
> tetex-xdvi-3.0-3  fonts-japanese-3.0-3

Sorry. fonts-japanese is 0.20050222-3.      

Comment 2 Jindrich Novy 2005-04-25 10:33:31 UTC
Could you please attach here some TeX source to produce Japanese dvi so that I
can test it after the fix?

Comment 3 Mamoru TASAKA 2005-04-25 13:15:16 UTC
Created attachment 113629 [details]
sample dvi file which needs Japanese font

Sample dvi file generated from Japanese tex file by platex.
This dvi file cannot be seen by pxdvi. Editing vfontmap works for
me.

Comment 4 Mamoru TASAKA 2005-04-25 13:24:26 UTC
Created attachment 113630 [details]
The source TeX document

And the source TeX file of the dvi file above.
This TeX document is encoded by EUC-JP.

Comment 5 Jindrich Novy 2005-04-25 13:51:14 UTC
Ok, thanks.


Note You need to log in before you can comment on or make changes to this bug.