Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155874 - snmpd will not start under fc3 default
Summary: snmpd will not start under fc3 default
Keywords:
Status: CLOSED DUPLICATE of bug 155873
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 06:22 UTC by Rob Kearey
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 19:29:14 UTC


Attachments (Terms of Use)

Description Rob Kearey 2005-04-25 06:22:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
snmpd will not start under fc3 with targeted policy enabled. It starts fine when selinux is set to permissive mode.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.96

How reproducible:
Always

Steps to Reproduce:
1. set selinux to enforcing mode
2. start snmpd
3. ... watch it silently fail
  

Actual Results:  snmpd fails to start

Expected Results:  snmpd should start as normail

Additional info:

audit(1114408867.443:0): avc:  denied  { read } for  pid=3785 exe=/usr/sbin/snmpd name=config dev=dm-0 ino=488072 scontext=root:system_r:snmpd_t tcontext=system_u:object_r:selinux_config_t tclass=file
audit(1114408867.444:0): avc:  denied  { getattr } for  pid=3785 exe=/usr/sbin/snmpd path=/etc/selinux/config dev=dm-0 ino=488072 scontext=root:system_r:snmpd_t tcontext=system_u:object_r:selinux_config_t tclass=file

Comment 1 Sitsofe Wheeler 2005-04-26 17:31:28 UTC
This look like a dup of bug #155873

Comment 2 Daniel Walsh 2005-04-26 19:29:14 UTC

*** This bug has been marked as a duplicate of 155873 ***


Note You need to log in before you can comment on or make changes to this bug.